Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58194 - [terminus-font] Wrong fontname in 70-no-bitmaps.conf

Attached to Project: Community Packages
Opened by Alexander Schnaidt (Namarrgon) - Wednesday, 11 April 2018, 00:05 GMT
Last edited by Johannes Löthberg (demize) - Tuesday, 01 January 2019, 18:45 GMT
Task Type Bug Report
Category Upstream Bugs
Status Closed
Assigned To Johannes Löthberg (demize)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
The included 75-yes-terminus.conf config needs to be adjusted for the fontconfig changes that now require the use of the "enriched" fontname, otherwise it will not override other configs, e.g. 70-no-bitmaps.conf

See:
https://bugs.archlinux.org/task/52508
http://git.savannah.gnu.org/cgit/freetype/freetype2.git/commit/?id=3576487add2f0e9691e8c43f8b0cd8e61aebf14f

The new name is "xos4 Terminus"

Steps to reproduce:
install community/terminus-font, enable 70-no-bitmaps.conf, "fc-list | grep -i terminus"
This task depends upon

Closed by  Johannes Löthberg (demize)
Tuesday, 01 January 2019, 18:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.47-2
Comment by Doug Newgard (Scimmia) - Wednesday, 11 April 2018, 13:46 GMT
File comes from upstream, not from Arch. You'll want to talk to them.
Comment by Alexander Schnaidt (Namarrgon) - Wednesday, 11 April 2018, 13:51 GMT
I will but since not every downstream switched to the enriched fontnames they will likely be less than enthused about changing this.

Loading...