FS#58158 - [linux] Flickering screen on AMDGPU with Linux 4.16-2

Attached to Project: Arch Linux
Opened by rainer (raneon) - Saturday, 07 April 2018, 19:57 GMT
Last edited by Jan Alexander Steffens (heftig) - Thursday, 19 April 2018, 09:18 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No


Description: I upgraded to Linux 4.16-2 from testing, but since then the screen is flickering with my AMDGPU and DC enabled. The flickering is visible especially on Plasma-Wayland as soon as you move the mouse, it is like a bright flickering, not like a graphical corruption. On SDDM or Plasma X11 the flickering is much less frequent, but even there the screen flickers from time to time. A downgrade to Linux 4.15 stable solved this.

Additional info:
* Linux 4.16-2 from testing
* AMDGPU.DC=1 (kernel parameter)

Steps to reproduce:
1. Ugrade to Linux 4.16.2 with AMDGPU.DC enabled on a RX480
2. Screen is flickering
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Thursday, 19 April 2018, 09:18 GMT
Reason for closing:  Fixed
Additional comments about closing:  4.16.2-2
Comment by loqs (loqs) - Saturday, 07 April 2018, 20:35 GMT
You had amdgpu.dc=1 set for 4.15 as well but the issue is only present on 4.16? If so have you reported the issue upstream?
Comment by rainer (raneon) - Saturday, 07 April 2018, 20:49 GMT
Yes, amdgpu.dc=1 is in my normal kernel parameters and works well with Linux 4.15. The only change was Linux 4.16-2. No, I didn't report it upstream, not sure what information I would have to provide and if this is related to the kernel only or Mesa as well. I see this only om my RX480, the small Vega APU on my Ryzen 5 2500U works well.
Comment by loqs (loqs) - Saturday, 07 April 2018, 21:02 GMT
https://bugzilla.kernel.org/ Product: Drivers Component: Video(DRI - non Intel) or https://bugs.freedesktop.org Product: DRI Component: DRM/AMDgpu
You could try https://aur.archlinux.org/packages/linux-amd-staging-drm-next-git/ first or bisect between 4.15 and 4.16 and find which commit is causing the issue.
General information on kernel bug reporting https://www.kernel.org/doc/html/latest/admin-guide/reporting-bugs.html
Comment by rainer (raneon) - Sunday, 08 April 2018, 10:19 GMT
I opened a bug https://bugzilla.kernel.org/show_bug.cgi?id=199319. I don't know how to bisect, but I might try linux-amd-staging-drm-next.
Comment by Christos Kotsaris (TemplarGR) - Friday, 13 April 2018, 15:21 GMT
Can confirm this bug on my R9 380 card as well. DC worked just fine for the 4.15.x series of kernels but as soon a i upgraded to 4.16.x kernels there is very noticable flickering. Issue is solved with amdgpu.dc=0.
Comment by loqs (loqs) - Friday, 13 April 2018, 19:53 GMT