Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58090 - [emacs-php-mode] Updated package requires php-project file which is not part of the package

Attached to Project: Community Packages
Opened by Chris Zimmermann (monochromec) - Wednesday, 04 April 2018, 07:03 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 21 June 2018, 16:54 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

File php-mode.el tries to include "php-project" which isn't part of the package.

Additional info:
* package version(s): 1.19.0-1
* config and/or log files etc.

Emacs prints: File error: Cannot open load file, No such file or directory, php-project

Steps to reproduce:

Put "(autoload 'php-mode "php-mode" "Major mode for editing php code" t)" and watch.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 21 June 2018, 16:54 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Wednesday, 04 April 2018, 15:00 GMT
Next time, include some reference to the package you're reporting a bug for so I don't have to go searching.
Comment by Albin Kauffmann (albinou) - Friday, 15 June 2018, 11:30 GMT
To fix this bug, I think it is just needed to add the following line to the PKGBUILD file:

install -D -m644 php-project.el "$pkgdir"/usr/share/emacs/site-lisp/php-project.el

Loading...