FS#5808 - Lilo missing depends

Attached to Project: Arch Linux
Opened by Sergej Pupykin (sergej) - Friday, 10 November 2006, 11:41 GMT
Last edited by Andreas Radke (AndyRTR) - Thursday, 14 December 2006, 13:55 GMT
Task Type Bug Report
Category Packages: Current
Status Closed
Assigned To Judd Vinet (judd)
Architecture not specified
Severity High
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


lilo depends on device-mapper. Please add device-mapper to depends.
This task depends upon

Closed by  Tobias Powalowski (tpowa)
Friday, 29 December 2006, 15:55 GMT
Reason for closing:  Fixed
Comment by Roman Kyrylych (Romashka) - Saturday, 11 November 2006, 11:00 GMT
Why it should? Last time I tried lilo it worked without device-mapper.
Are you sure that this is _strict_ dependency?
Comment by Sergej Pupykin (sergej) - Saturday, 18 November 2006, 13:53 GMT
# ldd /sbin/lilo
libdevmapper.so.1.02 => /lib/libdevmapper.so.1.02 (0x00002b69480b7000)
libc.so.6 => /lib/libc.so.6 (0x00002b69481c8000)
/lib/ld-linux-x86-64.so.2 (0x00002b6947f9c000)

# uname -a
Linux aserver 2.6.18 #1 PREEMPT Wed Sep 20 13:24:08 MSD 2006 x86_64 AMD Athlon(tm) 64 Processor 3200+ AuthenticAMD GNU/Linux

it is x86_64 only bug
Comment by Andreas Radke (AndyRTR) - Thursday, 14 December 2006, 13:55 GMT
it's a new feature from 22.7.3 release - Changelog: - Install device-mapper patches. (geometry.c, Makefile)

the makefile detects if device-mapper is installed. so it's more a feature request if we should sed it out or want to add device-mapper as a dep.

i vote for adding the dependency. i will fix the x86_64 pkg that way and reassign the bug to Judd to decide about the feature.
Comment by Roman Kyrylych (Romashka) - Thursday, 14 December 2006, 14:27 GMT
You mean makedepends, not depends, right?
Comment by Andreas Radke (AndyRTR) - Thursday, 14 December 2006, 17:18 GMT
no, if lilo is linked against libdevmapper.so.1.02 we need it also as a real dependency.

x86_64 is fixed now. this will also solve lilo not working on the iso.