Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58050 - mesa 17.3.7-1 causes frequent short system freezes

Attached to Project: Arch Linux
Opened by Tom (Semi) - Saturday, 31 March 2018, 12:37 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 16 April 2018, 14:09 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Jan Steffens (heftig)
Laurent Carlier (lordheavy)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:
The upgrade from mesa 17.3.6-1 to 17.3.7-1 introduced frequent short system freezes of about half a second. Visible for example when moving the mouse (mouse stops moving then later jumps across the screen), typing (one letter is repeated all the time after just typing once) or an unresponsive system in general.

In the kernel logs messages like this appear:
mrt 31 12:09:44 laptop kernel: ACPI: \_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
mrt 31 12:10:42 laptop kernel: ACPI: \_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
mrt 31 12:11:04 laptop kernel: ACPI: \_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
mrt 31 12:11:35 laptop kernel: ACPI: \_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM
mrt 31 12:12:06 laptop kernel: ACPI: \_SB_.PCI0.PEG0.PEGP: failed to evaluate _DSM

Downgrading to mesa 17.3.6-1 solves the issue and the log messages.

The issue is also described by other archlinux users:
https://bbs.archlinux.org/viewtopic.php?id=235686
https://www.reddit.com/r/archlinux/comments/872bpf/short_mouse_and_keyboard_freezes/

Hardware:
CPU i5-3380M CPU 2.90GHz
Intel 3rd Gen Core processor Graphics Controller
GPU nVidia GK107M [GeForce GTX 660M]

Software:
mesa 17.3.7-1
linux 4.15.13-1
gdm 3.28.0-1
gnome-shell 3.28.0-1
xf86-video-intel 1:2.99.917+812+g75795523-1
xf86-video-nouveau 1.0.15-2

Steps to reproduce:
Upgrade mesa to 17.3.7-1, reboot and and use the system for a minute and notice the freezes and messages in the kernel logs.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 16 April 2018, 14:09 GMT
Reason for closing:  Fixed
Comment by Tom (Semi) - Saturday, 31 March 2018, 12:47 GMT
Issue only occurs with:
wayland 1.14.0-1
weston 3.0.0-2

Not with Gnome on Xorg.
Comment by Michael Platzer (mplatzer) - Tuesday, 03 April 2018, 12:54 GMT
Same issue here, on a Lenovo T570 with an Intel HD Graphics 620, although in my case I resolved the issue by downgrading gnome-session to 3.28.0-1.

Versions:
mesa 17.3.7-1
linux 4.15.14-1
gdm 3.28.0-1
gnome-shell 3.28.0-1
gnome-session 3.28.0-2 (downgraded to 3.28.0-1 to fix)
Comment by Tom (Semi) - Friday, 06 April 2018, 16:23 GMT
Downgrading gnome-session to 3.28.0-1 does not fix the issue for me.

The problem persists with mesa 18:
mesa 18.0.0-2
linux 4.15.15-1
gdm 3.28.0-1
gnome-shell 3.28.0-1
gnome-session 3.28.0-2
Comment by Tom (Semi) - Saturday, 14 April 2018, 13:29 GMT
Issue seems to be fixed for me.

mesa 18.0.0-3
linux 4.15.15-1
gdm 3.28.1-1
gnome-shell 3.28.1-1
gnome-session 3.28.1-1
Comment by François Bastien (efemero) - Monday, 16 April 2018, 08:33 GMT
mesa 18.0.0-4 fixed the issue for me (did’nt tried 18.0.0-3)

Loading...