Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58046 - [abcde] Requires Mojo::base Perl module

Attached to Project: Community Packages
Opened by Jorispilot (Jorispilot) - Saturday, 31 March 2018, 08:59 GMT
Last edited by Jakob Gruber (schuay) - Tuesday, 03 April 2018, 16:12 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Jakob Gruber (schuay)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: abcde seems to require the perl module: Mojo::Base. This aborts the program. The only module I have found is perl-mojo-base-xs (in the AUR), which does not make abcde to work.

Additional info:
* package version(s): 2.9.1-2


Steps to reproduce:

$ abcde
Can't locate Mojo/Base.pm in @INC (you may need to install the Mojo::Base module) (@INC contains: /usr/lib/perl5/5.26/site_perl /usr/share/perl5/site_perl /usr/lib/perl5/5.26/vendor_perl /usr/share/perl5/vendor_perl /usr/lib/perl5/5.26/core_perl /usr/share/perl5/core_perl) at /usr/share/perl5/vendor_perl/WebService/MusicBrainz.pm line 4.
BEGIN failed--compilation aborted at /usr/share/perl5/vendor_perl/WebService/MusicBrainz.pm line 4.
Compilation failed in require at /usr/bin/abcde-musicbrainz-tool line 19.
BEGIN failed--compilation aborted at /usr/bin/abcde-musicbrainz-tool line 19.
[ERROR] abcde: abcde-musicbrainz-tool failed to run; ABORT
This task depends upon

Closed by  Jakob Gruber (schuay)
Tuesday, 03 April 2018, 16:12 GMT
Reason for closing:  Fixed
Additional comments about closing:  Switched to cddb as the default CDDBMETHOD in 2.9.1-3.
Comment by Jorispilot (Jorispilot) - Sunday, 01 April 2018, 10:36 GMT
I could make abcde work by manually installing per modules:

> cpan
> install Mojo::Base
> install WebService::MusicBrainz

However this seems not ideal for a package not to work out of the box…
Comment by Jakob Gruber (schuay) - Monday, 02 April 2018, 16:26 GMT
I wonder what changed. Looking back at 2.8.1, musicbrainz was already the default there.

Looks like perl-webservice-musicbrainz and perl-musicbrainz-discid (currently in the AUR) are now hard dependencies.
Comment by Jakob Gruber (schuay) - Monday, 02 April 2018, 16:27 GMT
I'm tempted to switch the default CDDBMETHOD to cddb to avoid having to add 3 new perl packages to [community].

Loading...