Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58028 - [gnome-control-center] Don't open

Attached to Project: Arch Linux
Opened by Marcelo Perini Veloso (marceloperini) - Thursday, 29 March 2018, 19:45 GMT
Last edited by Doug Newgard (Scimmia) - Monday, 02 April 2018, 15:10 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 2
Private No

Details

Description:
I've tried to access my settings through the search bar in activities and tried to access user settings in Gnome, yet none of them will open.

Additional info:
* package version(s): 3.28.0


Steps to reproduce:

Run in gnome-terminal:
$ gnome-control-center
This task depends upon

Comment by Doug Newgard (Scimmia) - Saturday, 31 March 2018, 03:59 GMT
What shows up in the terminal?
Comment by Dominik Opyd (inder) - Monday, 02 April 2018, 14:05 GMT
I have the same problem, since the update on Gnome 3.28 has stopped opening.

Terminal: "Failed to register: Timeout"

Journalctl: failed to rescan: Failed to parse /usr/share/applications/gnome-control-center.desktop file: cannot process file of type application/x-desktop

killall gnome-control-center | fix the problem and open work fine.
Comment by Jordi Chulia (jorchube) - Wednesday, 04 April 2018, 17:34 GMT
Since this report does not give me enough information to discern whether this is my case or not, I'll put this here:

gnome-control-center fails to start with a segmentation fault occasionally. I have attached the journalctl log (which I think will not be very useful).

I've start noticing this since I installed and enabled cups (both enabling the systemd service and the socket alternatively).

I can more or less consistently reproduce it by opening the gnome-control-center, going to Devices->printers and closing the gnome-control-center. The next time it is launched it segfaults. There is one printer added.

local/gnome-control-center 3.28.0-1
local/system-config-printer 1.5.11-2
local/cups 2.2.7-1
local/cups-filters 1.20.1-3
local/cups-pk-helper 0.2.6-1
local/libcups 2.2.7-1
local/python-pycups 1.9.73-3
Comment by Marcelo Perini Veloso (marceloperini) - Wednesday, 04 April 2018, 17:58 GMT Comment by Martin Anantharaman (MAnantharaman) - Wednesday, 20 June 2018, 11:20 GMT
Another discussion on this at reddit (https://www.reddit.com/r/archlinux/comments/75zpfe/gnomecontrolcenter32611_is_empty/) also provides a solution I could confirm. Further, there is an up-stream bug-report (https://bugzilla.gnome.org/show_bug.cgi?id=793117) initiated by https://bugzilla.gnome.org/show_bug.cgi?id=793117 - but pretty dormant, do you have some leverage as representative o Arech distribution to expedite this?

ANOTHER problem I have on my ancient Pentium+865G Dell is that some dialogues do not display properly, IMHO because the SILENTLY assume suffiocient OpenGL support without checking:-(
Comment by Jan de Groot (JGC) - Wednesday, 20 June 2018, 22:34 GMT
gnome-control-center is unsupported in other desktops. The window is filled with entries by using .desktop files, they have OnlyShowIn=GNOME;Unity; in them.
https://bugs.archlinux.org/task/56054

This bugreport is about not being able to start gnome-control-center from GNOME, which is a valid bug. Don't add other issues to it please.

Loading...