Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58027 - [hostapd] setting logger_syslog=0 in the configuration files does not eliminate logging

Attached to Project: Community Packages
Opened by Fabio (fabioca) - Thursday, 29 March 2018, 16:32 GMT
Last edited by David Runge (dvzrv) - Thursday, 17 October 2019, 17:28 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
David Runge (dvzrv)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I use hostapd in my access point server. Everything works fine, but it produces too much logging for my taste. For instance, the system log is flooded with messages like the this one every few seconds.

Mar 30 00:24:03 archimede hostapd[23369]: wlan-internal: AP-STA-POLL-OK 2c:44:fd:71:31:4c
Mar 30 00:24:15 archimede hostapd[23369]: wlan-internal: AP-STA-POLL-OK 2c:44:fd:71:31:4c
Mar 30 00:24:33 archimede hostapd[23369]: wlan-internal: AP-STA-POLL-OK 2c:44:fd:71:31:4c
Mar 30 00:24:49 archimede hostapd[23369]: wlan-internal: AP-STA-POLL-OK 2c:44:fd:71:31:4c
Mar 30 00:25:00 archimede hostapd[23369]: wlan-internal: AP-STA-POLL-OK 2c:44:fd:71:31:4c
Mar 30 00:25:21 archimede hostapd[23369]: wlan-internal: AP-STA-POLL-OK 2c:44:fd:71:31:4c
Mar 30 00:25:50 archimede hostapd[23369]: wlan-internal: AP-STA-POLL-OK 2c:44:fd:71:31:4c

In the configuration file I added the lines below, but it did not make any difference. The message above seems like an INFO level message, not a WARNING level message, so I would expect that setting the level to 4 should eliminate it. Plus the bitmask is set to zero, which should disable any logging. I also tried to set the log level to 5, but even that did not solve the problem.

logger_syslog=0
logger_syslog_level=4
logger_stdout=0
logger_stdout_level=4

Am I doing something wrong? Is it some compilation flags missing in the Arch package? Should I report upstream? What is the appropriate forum?

Additional info:
* package version(s)
hostapd 2.6-7


Steps to reproduce:
Set up hostapd, connect an idle device to it (In the example below it is a network printer). Check the journal log.
This task depends upon

Closed by  David Runge (dvzrv)
Thursday, 17 October 2019, 17:28 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Tuesday, 03 April 2018, 17:59 GMT
You added the logger lines to the configuration file, but were they already present earlier in the file? They are in the sample file.
Comment by Fabio (fabioca) - Wednesday, 04 April 2018, 01:47 GMT
My configuration is based on the example file located at:
https://w1.fi/cgit/hostap/plain/hostapd/hostapd.conf
where the logger lines are present but with different numeric value. The default values generate verbose logging as well.

My full configuration file (with password changed) is attached. There are 2 ssid: the log reported relates to the first ssid, i.e. ARCHIMEDE-2.

Regards
Comment by David Runge (dvzrv) - Monday, 23 September 2019, 21:11 GMT
@fabioca: To my knowledge these messages are normal. I also think logger_syslog=0 doesn't do what you expect it to do (from /etc/hostapd/hostapd.conf):

```
# hostapd event logger configuration
#
# Two output method: syslog and stdout (only usable if not forking to
# background).
#
# Module bitfield (ORed bitfield of modules that will be logged; -1 = all
# modules):
# bit 0 (1) = IEEE 802.11
# bit 1 (2) = IEEE 802.1X
# bit 2 (4) = RADIUS
# bit 3 (8) = WPA
# bit 4 (16) = driver interface
# bit 5 (32) = IAPP
# bit 6 (64) = MLME
#
# Levels (minimum value for logged events):
# 0 = verbose debugging
# 1 = debugging
# 2 = informational messages
# 3 = notification
# 4 = warning
```

I would like to close this, as this has nothing to do with the package. If at all, this is an upstream or configuration issue.

Loading...