Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#58003 - [emacs-php-mode] needs !makeflags option to prevent concurrency

Attached to Project: Community Packages
Opened by Kevin Mihelich (kmihelich) - Wednesday, 28 March 2018, 13:57 GMT
Last edited by Sergej Pupykin (sergej) - Friday, 22 June 2018, 16:29 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: Multi-threaded builds of this package do not appear to be safe. There is a race condition such that a parallel make causes a needed file to be locked, stalling the build. Supplying the !makeflags option to prevent concurrency solves the problem.


Additional info:
* package version: 1.19.0-1
* log snippet:
Generating autoloads for php-mode.el...done
Generating autoloads for php-mode.el...
Generating autoloads for php-project.el...
Generating autoloads for php-project.el...done
Saving file /build/emacs-php-mode/src/php-mode-1.19.0/php-mode-autoloads.el...
.../php-mode-autoloads.el locked by builduser@lem... (pid 1259): (s, q, p, ?)?


Steps to reproduce: Build with MAKEFLAGS -j > 1. This will not fail every time.
This task depends upon

Closed by  Sergej Pupykin (sergej)
Friday, 22 June 2018, 16:29 GMT
Reason for closing:  Fixed
Comment by Eli Schwartz (eschwartz) - Wednesday, 28 March 2018, 15:01 GMT
The solution is to hardcode -j1, really...

If someone wishes to use other flags with Make we shouldn't prevent that. Just override the one thing which needs to be changed.

...

Have you filed an upstream bug to fix this? I don't see one: https://github.com/ejmr/php-mode/issues
Comment by Eli Schwartz (eschwartz) - Thursday, 21 June 2018, 21:40 GMT
This is not fixed, since we ourselves still cannot always build it. ;)

But I don't understand why we're running make at all, since we don't even package the resulting byte-compiled *.elc files or php-mode-autoloads.el
Comment by Sergej Pupykin (sergej) - Thursday, 21 June 2018, 22:41 GMT
emacs-php-mode-1.19.1-3 should be better

Loading...