Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57994 - [networkmanager] "systemd" makedepends is listed twice in PKGBUILD

Attached to Project: Arch Linux
Opened by Francisco Pina (Stunts) - Tuesday, 27 March 2018, 15:19 GMT
Last edited by Jan Alexander Steffens (heftig) - Tuesday, 27 March 2018, 17:53 GMT
Task Type General Gripe
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Very Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
In the PKGBUILD for networkmanager 1.10.6-3 the makedepends array contains the following:

makedepends=(intltool dhclient iptables gobject-introspection gtk-doc "ppp=$_pppver" modemmanager
dbus-glib iproute2 nss polkit wpa_supplicant curl systemd libmm-glib
libnewt libndp libteam vala perl-yaml python-gobject git vala jansson bluez-libs
glib2-docs dhcpcd systemd)

I have noticed that "systemd" is listed twice. I don0t think it causes ant problems, but it seems to be just redundant.

Additional info:
* networkmanager-1.10.6-3


Steps to reproduce:

Just look at the PKGBUILD (https://git.archlinux.org/svntogit/packages.git/tree/trunk/PKGBUILD?h=packages/networkmanager).
This task depends upon

Closed by  Jan Alexander Steffens (heftig)
Tuesday, 27 March 2018, 17:53 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in trunk, thanks.

Loading...