Pacman

Welcome to the Pacman bug tracker. Please search the current bugs and feature requests before filing a new one! Use advanced search and select "Search in Comments".

* Please select the correct category and version.
* Write a descriptive summary, background info, and provide a reproducible test case whenever possible.
Tasklist

FS#5798 - --syncdeps option for -A/-U

Attached to Project: Pacman
Opened by Thomas B├Ąchler (brain0) - Thursday, 09 November 2006, 00:03 GMT
Last edited by Xavier (shining) - Tuesday, 15 September 2009, 10:06 GMT
Task Type Feature Request
Category General
Status Closed
Assigned To Aaron Griffin (phrakture)
Dan McGee (toofishes)
Architecture All
Severity Medium
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version 3.4.0
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Add a --syncdeps option for -U/-A operations: This would install the file with -U/-A, but install all dependencies as if you would -S them (except the "Reason" field, which would be "installed as a depdendency" in this case).
Closed by  Xavier (shining)
Tuesday, 15 September 2009, 10:06 GMT
Reason for closing:  Implemented
Additional comments about closing:  commit 0da96abc90 (syncdeps would be the default behavior, so no option for now)
Comment by Roman Kyrylych (Romashka) - Wednesday, 14 February 2007, 22:23 GMT
This will be very useful option, especially for packagers, because now I have to rebuild local repo with gensync after each makepkg run when getting PKGBUILD to build, then install package and deps with -S and then remove package from cache. Err.
Comment by Roman Kyrylych (Romashka) - Friday, 16 February 2007, 19:42 GMT
Similar FR posted by codemac: http://bugs.archlinux.org/task/6042
Comment by Dan McGee (toofishes) - Sunday, 08 April 2007, 07:26 GMT
Similar old bug, had to close one of them: http://bugs.archlinux.org/task/4926
Comment by Nagy Gabor (combo) - Wednesday, 09 January 2008, 13:19 GMT Comment by Gavin Bisesi (Daenyth) - Thursday, 19 June 2008, 18:26 GMT
It's worth noting that you can -S --asdeps, so this isn't impossible currently. I think it worth implementing, though.
Comment by Xavier (shining) - Thursday, 09 July 2009, 11:32 GMT
This is implemented in Nagy universal branch : http://repo.or.cz/w/pacman-ng.git?a=shortlog;h=refs/heads/universal

Loading...