Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57948 - Problems with fontconfig and Mathematica.

Attached to Project: Arch Linux
Opened by Dominik Schrempf (dschrempf) - Sunday, 25 March 2018, 12:26 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 25 March 2018, 16:01 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Problems with fontconfig and Mathematica.

Additional info:
* package version(s)
Name : fontconfig
Version : 2.13.0+10+g58f5285-1
Mathematica 11.2

Steps to reproduce:
Upgrade to fontconfig 2.13, start Mathematica.

The following error is reported.
/usr/local/Wolfram/Mathematica/11.2/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /usr/lib/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var

I tried to downgrade to fontconfig-2.12.6+5+g665584a-1-x86_64.pkg.tar.xz, but then I get a bootloop when starting LightDM.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 25 March 2018, 16:01 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Sunday, 25 March 2018, 14:39 GMT
With what version of freetype2?
Comment by Herman Yanush (Sheogorath) - Sunday, 25 March 2018, 15:09 GMT
@Scimmia I have freetype2 2.9-2 and the same problem.
Comment by Doug Newgard (Scimmia) - Sunday, 25 March 2018, 15:12 GMT
Not with the same error, I would bet.
Comment by Herman Yanush (Sheogorath) - Sunday, 25 March 2018, 15:49 GMT
No it's the same. The only difference is that I have Mathematica on the other partition.
/media/mintroot/usr/local/Wolfram/Mathematica/11.2/SystemFiles/FrontEnd/Binaries/Linux-x86-64/Mathematica: symbol lookup error: /usr/lib/libfontconfig.so.1: undefined symbol: FT_Done_MM_Var
Comment by Doug Newgard (Scimmia) - Sunday, 25 March 2018, 15:57 GMT
Is Mathematica distributing it's own libfreetype?
Comment by gspada (gspada) - Sunday, 25 March 2018, 15:59 GMT
I had the same problem. Found a solution here:
https://forums.gentoo.org/viewtopic-p-8198000.html?sid=ab27c1ca8e1927691858595185e18284

Just remove or rename the mathematica freetype.so.6 and libz.so libraries in the directory ${TopDirectory}/SystemFiles/Libraries/Linux-x86-64

Loading...