Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57912 - [gnome-shell] crash when calling meta_window_x11_new

Attached to Project: Arch Linux
Opened by Antonio Corbi bellot (acorbi) - Wednesday, 21 March 2018, 12:54 GMT
Last edited by Doug Newgard (Scimmia) - Sunday, 15 April 2018, 14:27 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

After updating to gnome-3.28 my laptop runing nouveau driver with a NVIDIA Corporation GK208M [GeForce 920M] (rev a1) and starting gnome-session on Xorg (but also on wayland) I get a gnome-shell coredump like this:

----------------------------------------------------------
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/usr/lib/libthread_db.so.1".
Core was generated by `/usr/bin/gnome-shell'.
Program terminated with signal SIGABRT, Aborted.
#0 0x00007f5478c39c70 in raise () from /usr/lib/libpthread.so.0
[Current thread is 1 (Thread 0x7f5478fdda00 (LWP 1733))]
(gdb) bt
#0 0x00007f5478c39c70 in raise () at /usr/lib/libpthread.so.0
#1 0x000055cd38c82542 in ()
#2 0x00007f5478c39dd0 in <signal handler called> ()
at /usr/lib/libpthread.so.0
#3 0x00007f54788a5860 in raise () at /usr/lib/libc.so.6
#4 0x00007f54788a6ec9 in abort () at /usr/lib/libc.so.6
#5 0x00007f5477b82e36 in g_assertion_message () at /usr/lib/libglib-2.0.so.0
#6 0x00007f5477b82e9c in g_assertion_message_expr ()
at /usr/lib/libglib-2.0.so.0
#7 0x00007f54760656c0 in () at /usr/lib/libmutter-2.so.0
#8 0x00007f547606cc0d in () at /usr/lib/libmutter-2.so.0
#9 0x00007f5476082f31 in meta_window_x11_new () at /usr/lib/libmutter-2.so.0
#10 0x00007f547605c01c in meta_screen_manage_all_windows ()
at /usr/lib/libmutter-2.so.0
#11 0x00007f547604d801 in meta_display_open () at /usr/lib/libmutter-2.so.0
#12 0x00007f547605741f in meta_run () at /usr/lib/libmutter-2.so.0
#13 0x000055cd38c81ff1 in ()
#14 0x00007f5478891f4a in __libc_start_main () at /usr/lib/libc.so.6
#15 0x000055cd38c8214a in ()
------------------------------------------------------

Additional info:

* package version(s)

gnome-shell 3.28.0-1
mutter 3.28.0-1
gnome-session 3.28.0-1
gnome-shell-extensions 3.28.0+1+g496ae16-1

* config and/or log files etc.

I start a fresh session environment with only the extensions provided by the gnome-shell-extesions package.

Steps to reproduce:

In my case trying to open some extensions preferences makes gnome-shell crash or starting some x11 apps (like XPaint) also make gnome-shell core dump.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Sunday, 15 April 2018, 14:27 GMT
Reason for closing:  Fixed
Comment by Antonio Corbi bellot (acorbi) - Wednesday, 21 March 2018, 13:25 GMT
I forgot to mention that nouveau version is:
xf86-video-nouveau 1.0.15-2
Comment by Mantas (sirex) - Sunday, 25 March 2018, 11:26 GMT
Not sure if this related, but today after upgrading to 3.28 gnome shell won't start. Attaching core dump info. Same thing happens with both, xorg and wayland.

Version:

gnome-shell 3.28.0-1
mutter 3.28.0-1
gnome-session 3.28.0-1
gnome-shell-extensions 3.28.0+1+g496ae16-1
Comment by Phil (The_Vulpecula) - Monday, 26 March 2018, 14:18 GMT
As noted by Mantas, since my update this morning, gnome-shell won't start. Just after entering my password, the following message is displayed in the logs:

Mar 26 10:17:34 archlinux gnome-shell[1854]: libnm symbols detected; Mixing libnm with libnm-util/libnm-glib is not supported


Comment by Jan de Groot (JGC) - Tuesday, 27 March 2018, 10:07 GMT
Mantas, Phil, your problems are unrelated to this bug.
Comment by Arsenii (ettavolt) - Friday, 13 April 2018, 08:35 GMT
I believe this happens only on laptops with discrete nvidia GPU and blob driver.
In my case (intel+nvidia):
If nvidia GPU is preemptively turned off via acpi_call the system is frozen (no X, no alternate console).
If it is turned on X session works as of gnome-session 3.28. To start wayland session I can stop gdm (including whatever sessions are started), rmmod nvidia_drm nvidia_modeset nvidia, start gdm.
If I blacklist nvidia nvidia_drm nvidia_modeset, but don't turn off nvidia GPU, wayland starts automatically.

Guess that's upstream bug, caused by recent support for hybrid GPU laptops. The strange thing is why it doesn't work with nouveau. Jonas Ã…dahl said he was testing i915+nouveau setup.
Comment by Antonio Corbi bellot (acorbi) - Friday, 13 April 2018, 10:46 GMT
Since the last bunch of gnome-related pkgs update (3.28.1) it seems it's working again. No more crashes.
I still don't use wayland and use nouveau instead of nvidia propietary driver.

So, at least for me, the bug is solved, don't know how but it's solved :)

Loading...