Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57903 - [systemd][dbus] "Failed to reload daemon: Message recipient"

Attached to Project: Arch Linux
Opened by Pedro Gabriel Drumond Pereira (pedrogabriel) - Tuesday, 20 March 2018, 15:42 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 22 March 2018, 15:19 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Dave Reisner (falconindy)
Christian Hesse (eworm)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

Description:
Everytime I enable or disable an service I got an message of "Failed to reload daemon: Message recipient disconnected from message bus without replying", sometimes some of the services refuse to work (mostly the NetworkManager).

Additional info:
systemd: 238.0-3
dbus: 1.12.6-1


Steps to reproduce:
- Enable or disable an service
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 22 March 2018, 15:19 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd 238.51-1
Comment by Pedro Gabriel Drumond Pereira (pedrogabriel) - Tuesday, 20 March 2018, 15:49 GMT
After posting it I got one "Failed to enable unit: Failed to activate service 'org.freedesktop.systemd1': timed out (service_start_timeout=25000ms)"
Comment by loqs (loqs) - Tuesday, 20 March 2018, 17:27 GMT
Issue appears new with systemd 238 and only occurs if polkit is used for authentication of a none root user instead of using sudo.
Comment by Chih-Hsuan Yen (yan12125) - Tuesday, 20 March 2018, 17:54 GMT
Looks relevant: https://github.com/systemd/systemd/pull/8473

I got the same issue with v238, and after building the latest commit of systemd (https://github.com/systemd/systemd/commit/5c24d6367597ac99327676c3c8df69bdf67952a3), `systemctl daemon-reload` works fine again.

PS. I built the latest commit instead of cherry-picking because v238 does not build now: https://github.com/systemd/systemd/pull/8456
PS2. https://github.com/systemd/systemd/pull/8296 adds /usr/bin/resolvconf, which conflicts with the openresolv package. I disable systemd-resolved (-Dresolve=false) to workaround it.
Comment by loqs (loqs) - Tuesday, 20 March 2018, 18:17 GMT
e63ebf71edd7947f29389c72e851d8df5c7bedda core: when reloading, delay any actions on journal and dbus connections
848e863acc51ecfb0f3955c498874588201d9130 basic/macros: rename noreturn into _noreturn_ (#8456)
backporting those two commits fixes the issue and allows a successful build on this system

Loading...