AUR web interface

**This is the bug tracker for the AUR web interface.**

Use this tracker to report bugs or make feature requests regarding the behaviour or implementation of the AUR software.
Please read the Reporting Bug Guidelines before filing a new task.
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

- Please report bugs related to Arch Linux official packages here: http://bugs.archlinux.org/index.php?project=1
- Please report bugs for [community] packages here: http://bugs.archlinux.org/index.php?project=5
- For any packages in the AUR contact the maintainer or leave a comment on the package's detail page.

Source Code:
https://projects.archlinux.org/aurweb.git/
Tasklist

FS#57894 - Add search by provides/satisfier to the RPC interface

Attached to Project: AUR web interface
Opened by Yu, Li Yu (afg) - Monday, 19 March 2018, 16:42 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 19 March 2018, 17:11 GMT
Task Type Feature Request
Category Backend
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version 4.6.0
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

libalpm has a function alpm_find_satisfier.
The web interface lists all the possible satisfiers for a dependency string.
A dependency string may be like "linux-api-headers>=4.10" which includes a version requirement
or "libcurl.so" which packages listed on their "provides" array, or even both.

I'd like to request the said functionality for the RPC interface, via adding a new search_by: "providers"

For example, wingpanel-git [1] depends on libgala.so, which is provided by gala-git or gala.
In this case, there is no way in the RPC that finds any of the two package.
There is no package named libgala.so [2] and libgala.so certainly does not exist in name-desc [3].

The desired RPC interface might look like:
/rpc/?v=5&type=search&search_by=providers&arg=libgala.so
Or maybe a bulk query like: (not sure whether this will kill the server though)
/rpc/?v=5&type=providers&arg[]=dep1&arg[]=dep2

Also as a side note, the functionality of the web interface seems to be provided by:
pkgfuncs.inc.php:212:pkg_providers()

Thank you.

[1] https://aur.archlinux.org/packages/wingpanel-git/
[2] https://aur.archlinux.org/rpc/?v=5&type=info&arg[]=libgala.so
[3] https://aur.archlinux.org/rpc/?v=5&type=search&search_by=name-desc&arg=libgala.so
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 19 March 2018, 17:11 GMT
Reason for closing:  Duplicate
Additional comments about closing:  FS#49090
Comment by Yu, Li Yu (afg) - Monday, 19 March 2018, 16:54 GMT
I just found this to some degree, might be a duplicate of FS#49090.

Loading...