Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57890 - NetworkManager service fails to start.

Attached to Project: Arch Linux
Opened by Antonio Costa (antoniotcosta) - Monday, 19 March 2018, 10:51 GMT
Last edited by Antonio Rojas (arojas) - Monday, 19 March 2018, 11:03 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: NetworkManager service fails to start. Apparently the new version of NetworkManager requires libpsl.so.6 and
libpsl.so.5 is installed.

Additional info:

# systemctl status NetworkManager.service
● NetworkManager.service - Network Manager
Loaded: loaded (/usr/lib/systemd/system/NetworkManager.service; enabled; vendor preset: disa>
Drop-In: /usr/lib/systemd/system/NetworkManager.service.d
└─NetworkManager-ovs.conf
Active: failed (Result: exit-code) since Mon 2018-03-19 10:49:32 WET; 15s ago
Docs: man:NetworkManager(8)
Process: 3345 ExecStart=/usr/bin/NetworkManager --no-daemon (code=exited, status=127)
Main PID: 3345 (code=exited, status=127)

Mar 19 10:49:32 punkipa systemd[1]: NetworkManager.service: Service hold-off time over, schedul>
Mar 19 10:49:32 punkipa systemd[1]: NetworkManager.service: Scheduled restart job, restart coun>
Mar 19 10:49:32 punkipa systemd[1]: Stopped Network Manager.
Mar 19 10:49:32 punkipa systemd[1]: NetworkManager.service: Start request repeated too quickly.
Mar 19 10:49:32 punkipa systemd[1]: NetworkManager.service: Failed with result 'exit-code'.
Mar 19 10:49:32 punkipa systemd[1]: Failed to start Network Manager.

Steps to reproduce:
# /usr/bin/NetworkManager
/usr/bin/NetworkManager: error while loading shared libraries: libpsl.so.6: cannot open shared object file: No such file or directory

This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 19 March 2018, 11:03 GMT
Reason for closing:  Fixed
Additional comments about closing:  networkmanager 1.10.6-2

Loading...