Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57886 - [gajim] Missing/unneeded dependencies

Attached to Project: Community Packages
Opened by Balló György (City-busz) - Sunday, 18 March 2018, 16:58 GMT
Last edited by Balló György (City-busz) - Saturday, 24 March 2018, 10:25 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Balló György (City-busz)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 3
Private No

Details

1. gtk3 is a missing dependency.

2. bind-tools (nslookup) is not needed since the resolver code was ported to GIO. [1]

3. gspell is used optionally instead of gtkspell for spelling support. [2][3]

4. geoclue2 is used optionally for location listener functionality to share current position. [4]

5. farstream, gst-plugins-ugly and gst-libav are used optionally for audio and video chat. [5][6]

6. avahi is needed for serverless chatting with autodetected clients in a local network. [7]

7. notification-daemon is not need to be listed as optional dependency, because a notification server is usually part of the desktop environments.

[1] https://dev.gajim.org/gajim/gajim/commits/master/gajim/common/resolver.py
[2] https://dev.gajim.org/gajim/gajim/blob/master/gajim/common/app.py#L267
[3] https://dev.gajim.org/gajim/gajim/blob/master/gajim/features_window.py#L64
[4] https://dev.gajim.org/gajim/gajim/blob/master/gajim/common/app.py#L238
[5] https://dev.gajim.org/gajim/gajim/blob/master/gajim/common/app.py#L215
[6] https://dev.gajim.org/gajim/gajim/blob/master/gajim/features_window.py#L80
[7] https://dev.gajim.org/gajim/gajim/blob/master/gajim/features_window.py#L48
This task depends upon

Closed by  Balló György (City-busz)
Saturday, 24 March 2018, 10:25 GMT
Reason for closing:  Fixed
Additional comments about closing:  gajim 1.0.0-2
Comment by Antonio Rojas (arojas) - Sunday, 18 March 2018, 18:42 GMT
Moved to community
Comment by Olli (coderkun) - Monday, 19 March 2018, 10:46 GMT
The executable “aplay” (package “alsa-utils”) is also required to play any notification sound (see attached log).
Comment by Philipp Hörist (lovetox) - Monday, 19 March 2018, 19:53 GMT
Hi,

Gajim Dev here

Please make python-keyring a hard dependency, otherwise all user passwords get stored in plaintext, if it is necessary also make a dependency on some keyring service like gnome keyring

In general the https://aur.archlinux.org/packages/gajim-git/ show a more complete list of the dependencys

thanks

Loading...