Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57873 - [nautilus] segmentation fault at the startup

Attached to Project: Arch Linux
Opened by Muflone (muflone) - Saturday, 17 March 2018, 12:29 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 24 March 2018, 17:05 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The new Nautilus 3.28.0.1 crashes immediately upon its startup.

The issue seems related to the file system scan, every other virtual fs like computer:// or network:// or trash:// or starred:// work fine as expected but whenever I try to access to a real file system location like /home or / the application crashes instantly

Additional info:
* nautilus 3.28.0.1-1

attached gdb trace file for nautilus initially opened with computer:// and then clicking the home folder
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 24 March 2018, 17:05 GMT
Reason for closing:  Fixed
Comment by Muflone (muflone) - Saturday, 17 March 2018, 12:32 GMT Comment by Jan de Groot (JGC) - Monday, 19 March 2018, 15:14 GMT
Can't reproduce this, so you might want to recompile nautilus with debug symbols to find out what makes it crash.
Comment by Muflone (muflone) - Saturday, 24 March 2018, 16:33 GMT
one week later the issue has gone.
maybe it's related to some update installed today.

let's close this

Loading...