Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57871 - [emacs] use-package error: Invalid hash table rehash size

Attached to Project: Arch Linux
Opened by Antonio Corbi bellot (acorbi) - Saturday, 17 March 2018, 09:28 GMT
Last edited by Jürgen Hötzel (juergen) - Sunday, 18 March 2018, 16:44 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jürgen Hötzel (juergen)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:

After the big update to gnome 3.28 trying to use emacs+use-package (with the gtk interface) yields an 'Invalid hash table rehash size: 1.0' error. If I start emacs in non-windowed mode (-nw) it works as expected.

Additional info:
* package version(s)
emacs 25.3-3

Steps to reproduce:
Start emacs with the windowed gtk interface, the mere invocation of (package-initialize) produces this error. Starting emacs in non-windowed mode makes emacs work as expected.
This task depends upon

Closed by  Jürgen Hötzel (juergen)
Sunday, 18 March 2018, 16:44 GMT
Reason for closing:  Works for me
Comment by Andriy Kmit' (madand) - Saturday, 17 March 2018, 13:19 GMT
I can confirm the issue.

Emacs Lisp interpreter is misbehaves in GUI mode. It discards decimal part of any float number, so 1.5 gets evaluated to 1.0 leading to the mentioned (package-initialize) error.

To see this just run GUI Emacs like this:
emacs -q --eval "(message (number-to-string 2.33333))"

The number 2.0 will be printed in minibuffer.

Also note that emacs package itself was NOT a part of the recent package upgrade that caused the issue, so the bug lies in some dependency.
Comment by Jürgen Hötzel (juergen) - Sunday, 18 March 2018, 14:37 GMT
I can't reproduce this issue. Using:

pacman -Q emacs gnome-desktop
emacs 25.3-3
gnome-desktop 1:3.28.0-1
Comment by Antonio Corbi bellot (acorbi) - Sunday, 18 March 2018, 16:19 GMT
Also solved for me.
Comment by Eli Schwartz (eschwartz) - Sunday, 18 March 2018, 16:21 GMT
Solved by what?
Comment by Andriy Kmit' (madand) - Sunday, 18 March 2018, 16:23 GMT
I enabled testing repos and after full system update the issue is gone for me too. I cannot say exactly which package updated resolved it though.
Comment by Antonio Corbi bellot (acorbi) - Sunday, 18 March 2018, 16:33 GMT
Hie Eli,

Exactly the same situation as Andriy, I don't know which package update exactly solved the problem.

Loading...