Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57869 - [pango] undefined symbol: g_log_structured_standard

Attached to Project: Arch Linux
Opened by James (thx1138) - Saturday, 17 March 2018, 01:56 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 17 March 2018, 02:54 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

For instance, window decorations fail. And then, "dependency hell", trying to back-out the package.

testing/pango 1.42.0-1

To start, for instance:

$ /usr/bin/firefox-developer-edition
XPCOMGlueLoad error for file /usr/lib/firefox-developer-edition/libmozgtk.so:
/usr/lib/libpango-1.0.so.0: undefined symbol: g_log_structured_standard
Couldn\'t load XPCOM.

So, disable testing, and re-install pango, to extra/pango 1.40.14-2.

But then, for instance:

$ vim /etc/pacman.conf
vim: symbol lookup error: /usr/lib/libatk-1.0.so.0: undefined symbol: g_log_structured_standard

So, back-out testing/atk 2.28.0+2+g32f5756-1, to extra/atk 2.26.1-1.

But, for instance:

$ vim /etc/pacman.conf
vim: symbol lookup error: /usr/lib/libgdk-3.so.0: undefined symbol: g_log_structured_standard

So, back-out testing/gtk3 3.22.29+4+gb485cf91b5-1, to extra/gtk3 3.22.28-1.

This, at least, seems to make things usable again, even though there are other dependencies from testing.

Hmm - I suppose this symbol "g_log_structured_standard" is suppose to come from somewhere other than pango, and that all of the packages, pango, atk, and gtk3 are effected. Google says this symbol is from glib, in which case either this is a pango issue, or instead, is a glib issue.

For the moment, though, this version of pango - not by itself - makes the system unusable.
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 17 March 2018, 02:54 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Saturday, 17 March 2018, 02:07 GMT
What version of glib2?
Comment by James (thx1138) - Saturday, 17 March 2018, 02:45 GMT
Hmm - ok, I have two machine - one has this problem, the other does not.

The machine with the problem has package "local/glib 2.54.0-3".

The machine without the problem has package "local/glib2 2.56.0+7+g66948ae23-1".

Searching for package "glib", the only "glib" package is in the AUR.

How is it that the, for instance, pango package seems to require the glib2 package, but does not have a dependency on it?

Changing-out glib for glib2 seems to solve the missing symbol problem, but there also seems to be a missing glib2 dependency for several packages.

Comment by Doug Newgard (Scimmia) - Saturday, 17 March 2018, 02:54 GMT
There is no glib package in the repos. Whatever you've got, it's not an Arch problem.

Loading...