Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57868 - [ejabberd] set correct HOME when creating user

Attached to Project: Community Packages
Opened by Uwe Sauter (UweSauter) - Friday, 16 March 2018, 22:08 GMT
Last edited by Sergej Pupykin (sergej) - Thursday, 19 April 2018, 13:04 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sergej Pupykin (sergej)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
While first installation of community/ejabberd a user "jabber" is created:

jabber:x:17:17::/var/empty/:/sbin/nologin

Further configuration requires to run

sudo -u jabber ejabberdctl register USER DOMAIN PASSWORD

which fails with "Failed RPC connection to the node ejabberd@localhost: nodedown" due to HOME being /var/empty/ instead of /var/lib/ejabberd. The failure is caused because ejabberdctl cannot write an Erlang cookie into /var/empty (insufficient permissions).
The fix to this is to change the HOME directory of user jabber to /var/lib/ejabberd/, either after installation of ejabberd or better during the installation by the script that create the user.

Additional info:
* package version(s)
community/ejabberd 18.01-1
* config and/or log files etc.


Steps to reproduce:
This task depends upon

Closed by  Sergej Pupykin (sergej)
Thursday, 19 April 2018, 13:04 GMT
Reason for closing:  Fixed
Additional comments about closing:  in svn/trunk only

Loading...