Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#5785 - abiword becomes default editor

Attached to Project: Arch Linux
Opened by Roman Kyrylych (Romashka) - Tuesday, 07 November 2006, 23:27 GMT
Last edited by Aaron Griffin (phrakture) - Thursday, 13 September 2007, 03:51 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Aaron Griffin (phrakture)
Architecture All
Severity Medium
Priority Normal
Reported Version 0.7.2 Gimmick
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

AbiWord becomes the default editor for .txt files and source viewer for web pages in Epiphany.
While the first problem is not as big. The second is bad.
This task depends upon

Closed by  Aaron Griffin (phrakture)
Thursday, 13 September 2007, 03:51 GMT
Reason for closing:  Won't implement
Additional comments about closing:  This .desktop file is from upstream. Please file the bug with them, we're generally not in the habit of modifying what the original authors intend
Comment by Jan de Groot (JGC) - Wednesday, 08 November 2006, 07:23 GMT
Rightclick a textfile, click properties and select a different editor as default application. Abiword can handle text/plain as Mime-type, as specified in the .desktop file. AFAIK the last installed application becomes the default application, unless you specify a preferred application.
Comment by Roman Kyrylych (Romashka) - Wednesday, 08 November 2006, 08:44 GMT
> Rightclick a textfile, click properties and select a different editor as default application.
I've already done this. This is not big problem for me.

But abiword is set as default viewer in epiphany. I suppose this is because application/xhtml+xml;text/
html; in abiword.desktop

Hmm.. strange, but now epiphany opens source in gedit. :-/

> AFAIK the last installed application becomes the default application, unless you specify a preferred application.
I've tried, but this seems to be not true. I removed and installed packages but no changes.

Anyway, now epiphany opens everything in gedit, no matter what I installed last.
This bug may be closed as "not a bug", sorry.
Comment by Roman Kyrylych (Romashka) - Monday, 21 May 2007, 19:01 GMT
abiword.desktop has:
MimeType=application/x-abiword;text/x-abiword;text/x-xml-abiword;text/plain;application/msword;application/rtf;application/vnd.plain;application/xhtml+xml;text/html;
IMO all (x)html mimetypes should be removed, as they are useless anyway (who would open HTML file in AbiWord, really?) and just cause this bug.
Comment by Roman Kyrylych (Romashka) - Monday, 21 May 2007, 19:07 GMT
Also, text/plain could be removed as well (Gnome has Gedit for this, editing plain text files with AbiWord is not quite common thing :P)

Loading...