Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57852 - [filesystem] myhostname should be last in nsswitch.conf

Attached to Project: Arch Linux
Opened by Szunti (Szunti) - Thursday, 15 March 2018, 13:34 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 15 March 2018, 15:27 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

From the manual (nss-myhostname(8)):
It is recommended to place "myhostname" last in the nsswitch.conf' "hosts:"
line to make sure that this mapping is only used as fallback,
and that any DNS or /etc/hosts based mapping takes precedence.

Additional info:
* package version: 2018.1-2
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Thursday, 15 March 2018, 15:27 GMT
Reason for closing:  Not a bug
Comment by Eli Schwartz (eschwartz) - Thursday, 15 March 2018, 15:27 GMT
If you want to follow what that manpage recommends, feel free to change it on your own system.

We explicitly moved away from doing this, as a result of FS#56684

Also see the links there to e.g. https://github.com/systemd/systemd/issues/1605

Loading...