Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#57837 - [firefox] No Sound With Jack Audio Sound Server

Attached to Project: Arch Linux
Opened by Turbo B (Turbo) - Wednesday, 14 March 2018, 13:41 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 15 March 2018, 03:53 GMT
Task Type Bug Report
Category Packages: Extra
Status Assigned
Assigned To Jan de Groot (JGC)
Jan Alexander Steffens (heftig)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 0
Private No


Description: With FF 59 (version 1 & 2) there is no sound playing trough jack audio sound server, jack seems to be enable via mozconfig (ac_add_options --enable-jack). Hve to turn off Jack to play sound with alsa (that is enable too in mozconfig (ac_add_options --enable-alsa).

Additional info:
* package version(s) FireFox 59

This task depends upon

Comment by Turbo B (Turbo) - Wednesday, 14 March 2018, 15:13 GMT
May be the following output can help you:

[Child 3604, MediaPlayback #1] WARNING: 7fcc9d8f6100 OpenCubeb() failed to init cubeb: file /build/firefox/src/mozilla-unified/dom/media/AudioStream.cpp, line 387
[Child 3604, MediaPlayback #3] WARNING: Decoder=7fcc91271e00 [OnMediaSinkAudioError]: file /build/firefox/src/mozilla-unified/dom/media/MediaDecoderStateMachine.cpp, line 3755
[Child 3604, MediaPlayback #3] WARNING: Decoder=7fcc91271e00 Decode error: NS_ERROR_DOM_MEDIA_MEDIASINK_ERR (0x806e000b) - OnMediaSinkAudioError: file /build/firefox/src/mozilla-unified/dom/media/MediaDecoderStateMachine.cpp, line 3453
Comment by Jan Alexander Steffens (heftig) - Thursday, 15 March 2018, 08:01 GMT
Try (temporarily) reducing security.sandbox.content.level to 0 and restart Firefox. If that works this is a sandboxing issue.
Comment by Turbo B (Turbo) - Thursday, 15 March 2018, 09:01 GMT
It's ok with security.sandbox.content.level to 0.

I have reported the bug to bugzilla [Bug 783733], here is there answer:

"Looks like the sandbox is blocking bind(). You could try Firefox 60 (where
we've moved audio to the chrome process to avoid sandbox restrictions in the
content process), although it's untested with JACK. Alternatively, you could
lower the sandbox level via the security.sandbox.content.level pref, but be
aware that you're reducing your security to get JACK working in that case."
Comment by Turbo B (Turbo) - Thursday, 15 March 2018, 13:17 GMT
I have tried Firefox 60 and JACK is back!

good news (for me ..)!
Comment by Dan MacDonald (danboid) - Wednesday, 19 December 2018, 22:44 GMT
Firefox v64.0 isn't working with JACK under Arch amd64 - videos refuse to play under YouTube when JACK is running, yet I can see JACK support is enabled in the PKGBUILD.

I have tried setting security.sandbox.content.level to 0 and I've also tried setting media.cubeb.sandbox to false yet no JACK ports appear for FireFox after restarting it.

When I exit FF, I get errors like so:

[Parent 10035, Gecko_IOThread] WARNING: pipe error: Broken pipe: file /build/firefox/src/mozilla-unified/ipc/chromium/src/chrome/common/, line 736
[Parent 10035, Gecko_IOThread] WARNING: pipe error (150): Connection reset by peer: file /build/firefox/src/mozilla-unified/ipc/chromium/src/chrome/common/, line 363
Comment by Turbo B (Turbo) - Thursday, 20 December 2018, 08:44 GMT
FF v64 is working well for me on Arch but no amd64 ..
Comment by Dan MacDonald (danboid) - Thursday, 20 December 2018, 08:51 GMT
Turbo B:

Are you running JACK standalone (as required to achieve low latencies when recording) or are you using the JACK PA sink? I have no use for the latter personally.

If you are running Firefox under JACK (and not PA/JACK), how did you get it to work?
Comment by Turbo B (Turbo) - Friday, 21 December 2018, 09:15 GMT
FireFox is running under Jack [no PulseAudio on my machines] ... I don't remember exactly how i did to get it work lol [it was a long time ago]...
In the beginning, i remember that i have follow this: [Multimedia Playback Section]
Hope this helps.
Comment by Dan MacDonald (danboid) - Friday, 21 December 2018, 10:09 GMT
Interesting. I had already tried all the suggestions listed in the Arch Wiki Firefox Multimedia page you linked to. It doesn't actually cover JACK, only PA and/or ALSA, so maybe the JACK instructions got removed? Might be worth trawling the wiki history.

I just tried everything suggested on that page again and I got a new/different error alongside the ones I posted previously:

IPDL protocol error: Handler returned error code!

###!!! [Parent][DispatchAsyncMessage] Error: PLayerTransaction::Msg_ReleaseLayer Processing error: message was deserialized, but the handler returned false (indicating failure)

You could try doing a diff of ~/.mozilla/firefox/something.default/prefs.js with that of a new prefs.js and see what options you changed, then we can get it documented on the Arch wiki if it fixes it for me too?

Comment by Turbo B (Turbo) - Friday, 21 December 2018, 12:21 GMT

One question: is there no images and no sound on YT or just no sound?
Comment by Dan MacDonald (danboid) - Friday, 21 December 2018, 12:29 GMT
Youtube videos don't play when JACK is running. You only see the first frame of a video but it never starts to actually play the video.
Comment by Turbo B (Turbo) - Friday, 21 December 2018, 12:44 GMT
the evidence ...
Comment by Turbo B (Turbo) - Friday, 21 December 2018, 12:52 GMT
Can you get sound from another site (e.g
Comment by Turbo B (Turbo) - Friday, 21 December 2018, 16:26 GMT
I have tried on a machine with manjaro and their FF version [as FF was at the installation], killed PA ran Jack and watched videos on YT ...
Comment by Turbo B (Turbo) - Saturday, 22 December 2018, 12:20 GMT
Since audio was moved to the chrome process to avoid sandbox restrictions in the
content process, with FF build with Jack enable [of course] and this one running [of course], you have nothing else to do in the FF preferences ... to watch videos, listen to music ...