Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57819 - [libdrm] rebuilding package produces libdrm depending on valgrind

Attached to Project: Arch Linux
Opened by Erich Eckner (deepthought) - Tuesday, 13 March 2018, 10:03 GMT
Last edited by Andreas Radke (AndyRTR) - Tuesday, 13 March 2018, 17:06 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Jan de Groot (JGC)
Andreas Radke (AndyRTR)
Laurent Carlier (lordheavy)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

If the package is rebuilt with extra-x86_64-build, the resulting libdrm claims to depend on valgrind:
> tar -OxJf libdrm-2.4.91-1-x86_64.pkg.tar.xz usr/lib/pkgconfig/libdrm.pc 2>/dev/null | grep valgrind
Requires.private: valgrind udev

However, the package in the repositories does not:
> tar -OxJf /var/cache/pacman/pkg/libdrm-2.4.91-1-x86_64.pkg.tar.xz usr/lib/pkgconfig/libdrm.pc 2>/dev/null | grep valgrind
%nothing%

Additional info:
* package version(s)
libdrm-2.4.91-1 (git revision d6723260c1453a7ed4fcbb730cbd17ee92818820)

Steps to reproduce:
> git checkout d6723260c1453a7ed4fcbb730cbd17ee92818820
> cd libdrm/repos/extra-x86_64
> extra-x86_64-build
> tar -OxJf libdrm-2.4.91-1-x86_64.pkg.tar.xz usr/lib/pkgconfig/libdrm.pc 2>/dev/null | grep valgrind
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Tuesday, 13 March 2018, 17:06 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.4.91-2
Comment by Erich Eckner (deepthought) - Tuesday, 13 March 2018, 10:12 GMT
It seems to build fine without valgrind, and then produce a package which does not claim to depend on valgrind.

Loading...