Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57798 - [systemd][systemd-networkd] Network is not set up

Attached to Project: Arch Linux
Opened by Vladimir (_v_l) - Monday, 12 March 2018, 01:16 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 13 March 2018, 01:40 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description: on one of my VPS host systemd 238-3 don't set up network, systemd-networkd is running but device is down and no address is assigned. systemd 237-64 works fine there.

Additional info:
* linux kernel: checked on 4.15.8 and 4.15.9;
* systemd: 237-64 works fine, systemd: 238-3 no network (didn't test with earlier 238 packages);
* libsystemd: 238-3.

From my point of view it is bizarre that systemd 237-64 works fine vs libsystemd 238-3.

Steps to reproduce:
I have no idea, because on other two VPSes (from other hosters) systemd works fine, as well as on several my "real" hosts. I would be thankful if someone give me a hint how to debug the situation.
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 13 March 2018, 01:40 GMT
Reason for closing:  Not a bug
Comment by Doug Newgard (Scimmia) - Monday, 12 March 2018, 17:10 GMT
Logs would the a good place to start.
Comment by Sean Enck (enckse) - Monday, 12 March 2018, 23:54 GMT
You should check if your network device names changed (this happened on vultr to me) for what you had configured for systemd-networkd (assuming you configured anything) - https://www.freedesktop.org/wiki/Software/systemd/PredictableNetworkInterfaceNames/

Otherwise logs
Comment by Vladimir (_v_l) - Tuesday, 13 March 2018, 00:14 GMT
Hello Doug,
> Logs would the a good place to start.
Nothing special, this is output of 'systemctl status systemd-networkd' for systemd 237-64:
```
* systemd-networkd.service - Network Service
Loaded: loaded (/usr/lib/systemd/system/systemd-networkd.service; enabled; vendor preset: enabled)
Active: active (running) since Mon 2018-03-12 03:54:28 MSK; 23h ago
Docs: man:systemd-networkd.service(8)
Main PID: 181 (systemd-network)
Status: "Processing requests..."
Tasks: 1 (limit: 2384)
CGroup: /system.slice/systemd-networkd.service
`-181 /usr/lib/systemd/systemd-networkd

Mar 12 03:54:27 node1.vl-lomov.ru systemd[1]: Starting Network Service...
Mar 12 03:54:28 node1.vl-lomov.ru systemd-networkd[181]: Enumeration completed
Mar 12 03:54:28 node1.vl-lomov.ru systemd[1]: Started Network Service.
Mar 12 03:54:28 node1.vl-lomov.ru systemd-networkd[181]: eth0: Interface name change detected, eth0 has been renamed to ens3.
Mar 12 03:54:28 node1.vl-lomov.ru systemd-networkd[181]: lo: Link is not managed by us
Mar 12 03:54:28 node1.vl-lomov.ru systemd-networkd[181]: ens3: IPv6 successfully enabled
Mar 12 03:54:28 node1.vl-lomov.ru systemd-networkd[181]: ens3: Gained carrier
Mar 12 03:54:30 node1.vl-lomov.ru systemd-networkd[181]: ens3: Gained IPv6LL
Mar 12 03:54:42 node1.vl-lomov.ru systemd-networkd[181]: ens3: Configured
```

With systemd 238-3 the output stops on 'eth0: Interface name change detected, eth0 has been renamed to ens3.' STOP! That's other name that shows me 'ip a' for systemd 238-3, the name is 'enp0s3'!

> You should check if your network device names changed (this happened on vultr to me) for what you had configured for systemd-networkd (assuming you configured anything)

Thank you Doug, I didn't thought that the name could be changed (I think it is due to 'hardware' change), after changing 'Name' in '.network' file network is up after reboot.

Please close this ticket.

Loading...