Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57773 - [ffmpeg2.8] Today's upgrade of x265 breaks ffmpeg dependency

Attached to Project: Arch Linux
Opened by Britt Yazel (brittyazel) - Friday, 09 March 2018, 16:53 GMT
Last edited by Levente Polyak (anthraxx) - Friday, 09 March 2018, 21:31 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 7
Private No

Details

Description:
Upon install updates today, I was greeted with:

error: failed to prepare transaction (could not satisfy dependencies)
:: ffmpeg2.8: installing x265 (2.7-1) breaks dependency 'libx265.so=146-64'

It seems that ffmpeg is requiring now an older version of x265 than exists in the package repos.
This task depends upon

Closed by  Levente Polyak (anthraxx)
Friday, 09 March 2018, 21:31 GMT
Reason for closing:  Fixed
Additional comments about closing:  2.8.13-7 temporarily readded.
Comment by Britt Yazel (brittyazel) - Friday, 09 March 2018, 16:58 GMT
Strange, so it was a weird cyclic dependency issue. VLC couldn't update because the old version required a package named ffmpeg2.8 (that doesn't seem to exist anymore), x265 couldn't update because that ffmpeg2.8 package required the older x265 for support, and I couldn't remove ffmpeg2.8 because the previous package of vlc (still installed) required it. The solution was to:

manually update VLC first --> manually remove ffmpeg2.8 --> then the updates would work as planned.
Comment by yurick gomes (yurick.gomes) - Friday, 09 March 2018, 21:16 GMT
I bypassed the error with 2 steps:
1 - sudo pacman -Rs vlc
2 - sudo pacman -S vlc

Everything is ok now
Comment by Levente Polyak (anthraxx) - Friday, 09 March 2018, 21:30 GMT
ffmpeg2.8 has temporarily been readded for a more fluent transition for packages supported by our repositories. It will be killed soon (~1month maybe slightly longer).
ffmpeg2.8 should be removed after upgrading to avoid future problems, it doesn't have any supported packages depending on it.

Loading...