Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57749 - [openldap] libtool relink errors during install

Attached to Project: Arch Linux
Opened by Andreas Baumann (andreas_baumann) - Thursday, 08 March 2018, 08:18 GMT
Last edited by Doug Newgard (Scimmia) - Thursday, 08 March 2018, 15:22 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

The overlays fail to install to $pkgdir with:

"libtool: install: error: relink `accesslog.la' with the above command before installing it "

My setup is a system/chroot NOT having openldap/libldap already installed.

So, in package_libldap the libraries are installed and in package_openldap the clients, servers,
overlays and the rest.

Now the problem is that those two installations happen in $pkgdir/libldap resp. $pkgdir/openldap.

for dir in clients servers doc/man/man{1,5,8}; do
pushd ${dir}
make DESTDIR="${pkgdir}" install
popd
done

This installs only the server and the client to $pkgdir/openldap, but now libtool comes
along and tries to relink against for instance -lldap_r. Now there is one in $pkgdir/libldap
but none in $pkgdir/openldap.

What makes matters worse, if there is a /usr/lib/libldap_r.so on the system/chroot, libtool
relinks against that one (which is maybe not so bad, as it will be installed there anyway
when installing the package).

One way I was able to bootstrap was to do the following in package_openldap:

# install also the libraries to $pkgdir/openldap
for dir in libraries clients servers doc/man/man{1,5,8}; do
^^^^^^^^^
pushd ${dir}
make DESTDIR="${pkgdir}" install
popd
done

make -C contrib/slapd-modules/autogroup prefix=/usr libexecdir=/usr/lib sysconfdir=/etc/openldap DESTDIR
="$pkgdir" install

# clean up to avoid file clashed with the libldap subpackage

rm -rf ${pkgdir}/usr/{lib,include,man3}

I realize, this is maybe not a bug per se, but it points to a fundemtal issue with
split packages (at least, when they use libtool for linking).

Additional info:
* package version(s): 2.4.45-4
This task depends upon

Closed by  Doug Newgard (Scimmia)
Thursday, 08 March 2018, 15:22 GMT
Reason for closing:  Not a bug
Additional comments about closing:  Builds fine in a clean chroot

Loading...