Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#57741 - [systemd] 238.0-1 causes segfault when booting linux-zen 4.15.7-1 and 4.15.6-1

Attached to Project: Arch Linux
Opened by Geoffrey Host (carbonchauvinist) - Wednesday, 07 March 2018, 15:16 GMT
Last edited by Christian Hesse (eworm) - Friday, 09 March 2018, 13:57 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Jan Steffens (heftig)
Christian Hesse (eworm)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No


Description: When upgrading systemd, libsystemd and systemd-sysvcompat from 237.64-1 to 238.0-1 I'm unable to boot into the 4.15.7-1 linux-zen kernel. Prior to the LUKS passphrase prompt, I receive the following segfault and hard freeze (transcribed):

systemd[1]: segfault at 56347c000000 ip 000072f24d0e9d933 sp 00007ffe4da249d0 error 4 in[7f24d0e1booo+1ae000]
systemd[1]: caught <SEGV>, dumped core as pid 119
systemd[1]: freezing execution

Downgrading the linux-zen kernel from 4.15.7-1 to 4.15.6-1 had no effect. Similarly, switching from a systemd initramfs to a busybox only delayed the onset of the segfault; I was then able to enter the LUKS passphrase at least - but received the same segfault immediately after.

My system is as follows:
Dell Precision 5510, i5-6440HQ, Intel HD 530

May be of import to note that I'm able to boot my other kernels (mainline, lts, stock 'linux') without issue with systemd, libsystemd and systemd-sysvcompat at 238.0-1. Additionally, when downgrading systemd, libsystemd and systemd-sysvcompat to 237.64-1 I am able to boot linux-zen successfully (both 4.15.7-1 and 4.15.6-1).

Additional info:
* package version(s)
* config and/or log files etc.

$ pacman -Q glibc systemd systemd-sysvcompat libsystemd linux-zen
glibc 2.26-11
systemd 238.0-1
systemd-sysvcompat 238.0-1
libsystemd 238.0-1
linux-zen 4.15.7-1

Steps to reproduce:

1. Have linux-zen kernel installed
2. Upgrade libsystemd, systemd and systemd-sysvcompat to version 238.0-1
This task depends upon

Closed by  Christian Hesse (eworm)
Friday, 09 March 2018, 13:57 GMT
Reason for closing:  Fixed
Additional comments about closing:  systemd 238.0-3
Comment by Daniel M. Capella (polyzen) - Wednesday, 07 March 2018, 16:09 GMT
The segfault comes after LUKS for me with busybox init hooks.
Comment by Maxim Sheviakov (mradermaxlol) - Wednesday, 07 March 2018, 16:54 GMT
Same here, using testing + linux-lqx 4.15.6. Had to downgrade {lib,}systemd and systemd-sysvcompat to make the system boot fine again. I have glibc 2.26-11 installed.
Comment by Antonio Corbi bellot (acorbi) - Wednesday, 07 March 2018, 17:52 GMT
Same happens here without LUKS.
I would also add that when booting with linux or linux-lts and systemd-238.0-1, the laptop works ok but when I issue the poweroff/reboot/halt command I get errors related to umounting /oldroot. Sorry, I don't have the exact messages but they appear each and every time the laptop is halted, rebooted or powered-off.
Going back to systemd 237.64-1 make these errors disappear.
Comment by Bartłomiej Piotrowski (Barthalion) - Wednesday, 07 March 2018, 18:28 GMT
Christian, do you have debug packages around for this pkgrel? (Oops, he's not subscribed.)
Comment by Geoffrey Host (carbonchauvinist) - Wednesday, 07 March 2018, 18:36 GMT
@acorbi, yes I get the same messages too - scroll by too fast to capture with perfect fidelity and can't find them in the logs. I was able to transcribe some here though:

Stopping Mointoring of LVM2 mirros, snapshots etc. using dmeventd or polling...
sd-umoun[2013]: Failed to unmount /oldroot: Device or resource busy
shutdown[1]: Unmounting '/oldroot' failed abnormally, child process 2013 aborted or exited non-zero
sd-remount[2018]: Failed to remount '/oldroot/sys/fs/cgroup/memory' read-only: Device or resource busy
shutdown[1]: Remounting '/oldroot/sys/fs/cgroup/memory' failed abnormally, child process 2018 aborted or exited non-zero
repeats for following /oldroot/sys/fs/cgroup/memory, /oldroot/sys/fs/cgroup/pids, /oldroot/sys/fs/cgroup/devices, /oldroot/sys/fs/cgroup/systemd

Seems to be related to following, not sure of relevance to this possible issue, apologies if I'm muddying the waters:

Comment by loqs (loqs) - Wednesday, 07 March 2018, 19:22 GMT
systemd issue 8155 should not be releated if you mask mkinitcpio-generate-shutdown-ramfs.service those messages should stop but the boot issue should remain.
Comment by Jan Steffens (heftig) - Wednesday, 07 March 2018, 22:41 GMT
Seems to have something to do with the CPU cgroup support behaving differently with MuQSS, as it crashes when/after "Mounting cgroup to /sys/fs/cgroup/cpuset of type cgroup with options cpuset."

Booting with systemd.unified_cgroup_hierarchy works.
Comment by Jan Steffens (heftig) - Wednesday, 07 March 2018, 23:48 GMT
systemd 238.0-2 reverts a problematic commit.
Comment by Jan Steffens (heftig) - Wednesday, 07 March 2018, 23:48 GMT Comment by Kyle Devir (QuartzDragon) - Friday, 09 March 2018, 13:16 GMT fixes this issue properly and has been merged into upstream. Can this replace the revert?