Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57671 - [xdg-utils] Backport a fix to make xdg-open usable under LXQt

Attached to Project: Arch Linux
Opened by Chih-Hsuan Yen (yan12125) - Wednesday, 28 February 2018, 03:08 GMT
Last edited by Andreas Radke (AndyRTR) - Friday, 16 March 2018, 20:00 GMT
Task Type Feature Request
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Currently, the `xdg-open` command in xdg-utils 1.1.2-1 is not usable due to an upstream bug [1][2]. Now the bug is fixed [3]. Please consider backporting the fix to Arch Linux, thanks!

[1] https://bugs.freedesktop.org/show_bug.cgi?id=81674
[2] https://github.com/lxde/lxqt/issues/1298
[3] https://cgit.freedesktop.org/xdg/xdg-utils/commit/?id=7d4360c64d94de53d907f13ca99837285e972ec6

Additional info:
extra/xdg-utils 1.1.2-1

Steps to reproduce:
1. Run LXQt
2. Create an empty text file foobar.txt
3. Run `xdg-open foobar.txt`

Notes for packagers:
1. perl-file-mimeinfo is necessary to make xdg-open working under LXQt. That package is currently an optional dependency.
2. pcmanfm-qt should be added as an optional dependency just like exo or pcmanfm.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Friday, 16 March 2018, 20:00 GMT
Reason for closing:  Fixed
Comment by Rikard Falkeborn (Herk) - Friday, 16 March 2018, 19:06 GMT
The fix is backported in 1.1.2-2. I'm unable to test but this bug can probably be closed.

Loading...