Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57650 - [vim-runtime] Upgrade to vim 8.0.1531-1 breaks restricted vim

Attached to Project: Arch Linux
Opened by Andreas Bilke (abilke) - Monday, 26 February 2018, 19:19 GMT
Last edited by Levente Polyak (anthraxx) - Monday, 26 February 2018, 22:45 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

Description:

The update to vim 8.0.1531-1 inserts the following to "/usr/share/vim/vimfiles/archlinux.vim"

19 " Move the swap file location to protect against CVE-2017-1000382
20 silent !install -d -m 700 ~/.vim/swap/ 2>&1 > /dev/null
21 set directory=~/.vim/swap/

Executing a restricted vim (like rview, rvim) results in the following:

Error detected while processing /usr/share/vim/vimfiles/archlinux.vim:
line 20:
E145: Shell commands not allowed in rvim
Press ENTER or type command to continue


Additional info:
* vim 8.0.1531-1 and ongoing
This task depends upon

Closed by  Levente Polyak (anthraxx)
Monday, 26 February 2018, 22:45 GMT
Reason for closing:  Fixed
Additional comments about closing:  8.0.1542-2

Loading...