Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57641 - [vim] 8.0.1542-1 creates big terminal gap after exiting vim

Attached to Project: Arch Linux
Opened by Khoa Duc Cao (khoacao96) - Monday, 26 February 2018, 06:03 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Monday, 26 February 2018, 08:57 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After exiting vim, the terminal now displays a huge gap that puts the prompt to the bottom of the screen.


Additional info:
* package version: 8.0.1542-1
* Tested terminal: termite
* config and/or log files etc: all config files are default


Steps to reproduce:
1. Open vim in the terminal.
2. Exit vim through ":q".
3. A huge gap is now displayed. (screenshot attached)

Further discussions on Reddit: https://www.reddit.com/r/vim/comments/805zvt/exiting_vim_leaves_a_huge_gap_in_my_terminal/

The issue seems to be related to /usr/share/vim/vimfiles/archlinux.vim, line 19-21, since it did not occur with vim-8.0.1476-1 and below.
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Monday, 26 February 2018, 08:57 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#57640 
Comment by Khoa Duc Cao (khoacao96) - Monday, 26 February 2018, 06:05 GMT
Screenshot is in the Reddit post.
Comment by Bartłomiej Piotrowski (Barthalion) - Monday, 26 February 2018, 08:07 GMT
Honestly I don't get the point of this file at all. Said CVE workaround ignores XDG_CONFIG_HOME (and why would I want to put my swap files into vim configuration in the first place?) and the file in general imposes dubious features that should be set by user or system administrator.

Loading...