Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57625 - [nvidia] When using nvidia prime vulkan is not detecting nvidia card as capable hardware.

Attached to Project: Arch Linux
Opened by Pedro Gabriel Drumond Pereira (pedrogabriel) - Saturday, 24 February 2018, 22:47 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 15 March 2018, 08:47 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Felix Yan (felixonmars)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
I am trying to make nvidia vulkan driver being detected, tried in zen, ck and lts kernels.
Already tried to remove vulkan-intel and lib32-vulkan-intel with no sucess, but when I'm with then installed my vulkan works (as a intel hardware)

Doing this snippet of code that is stated in wiki also didn't work.

export VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/nvidia_icd.json

I tried to see if vulkan works using the game Talos Principle from steam, the game runs in opengl, but when I change to vulkan it crashs instantly.
I also tried to test if it was seen in vulkanCapsViewer, but when I don't have vulkan-intel installed I got an error "Could not enumarted device count" and then it not show my nvidia card as it should.

Packages:
- nvidia-dkms 390.25-11
- vulkan-intel 17.3.4-1
- mesa 17.3.4-1
- xorg-server 1.19.6+13+gd0d1a694f-1
- xorg-xrandr 1.5.0-1
- linux-zen 4.15.5-1
- linux-ck 4.15.5-1

Steps to reproduce:
* Install and setup nvidia prime
* Try to run any vulkan software
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 15 March 2018, 08:47 GMT
Reason for closing:  Not a bug
Comment by Pedro Gabriel Drumond Pereira (pedrogabriel) - Wednesday, 07 March 2018, 23:29 GMT
Nevermind, my card is not supported by nvidia vulkan. I'll never buy their trash again.

Loading...