Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57614 - [collectd] Collectd built with libpython2 and does not work with plugins written in Python3

Attached to Project: Community Packages
Opened by Benoit Walter (bwalter) - Friday, 23 February 2018, 16:14 GMT
Last edited by Gaetan Bisson (vesath) - Sunday, 04 March 2018, 07:16 GMT
Task Type Feature Request
Category Packages
Status Closed
Assigned To Gaetan Bisson (vesath)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
The package is built with python2. Python3 plugins do not work (even when forcing version). Would be great to change this package to be built with python3 instead.

Additional info:
* package version(s)
* config and/or log files etc.


Steps to reproduce:
- Try to create a plugin written python3
- Will still use python2
This task depends upon

Closed by  Gaetan Bisson (vesath)
Sunday, 04 March 2018, 07:16 GMT
Reason for closing:  Implemented
Additional comments about closing:  collectd-5.8.0-4 in [community]
Comment by Gaetan Bisson (vesath) - Saturday, 24 February 2018, 03:56 GMT
What about python2 plugins? Do you suggest to drop them all? Or are you aware of a way to build support for both python versions?
Comment by Benoit Walter (bwalter) - Saturday, 24 February 2018, 07:16 GMT
I could not find any collectd python2 plugin in the repository. In that case it would be probably an issue as using both python2 and python3 plugin is not likely to work. But are there such dependencies?
Comment by Gaetan Bisson (vesath) - Saturday, 24 February 2018, 19:21 GMT
Hm. Alright. I thought python3 support had been asked before but cannot find a trace of that. So we'll try again! :)
Comment by Gaetan Bisson (vesath) - Saturday, 24 February 2018, 19:24 GMT
Can you please test collectd-5.8.0-4 from [community-testing]?
I'll leave it there for a week to make sure nobody is too unhappy with it before moving it to [community].

Loading...