Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57596 - [ncurses] tmux crashdumps when starting neovim 0.2.2-2

Attached to Project: Arch Linux
Opened by Thomas Preissler (tomtom) - Wednesday, 21 February 2018, 13:29 GMT
Last edited by Eli Schwartz (eschwartz) - Thursday, 08 March 2018, 22:38 GMT
Task Type Bug Report
Category Packages: Core
Status Assigned   Reopened
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Medium
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

Description: When starting NVIM 0.2.2-2 within TMUX 2.6-2 tmux crashdumps immediately.

I have submitted a bugreport to tmux, https://github.com/tmux/tmux/issues/1264, already about this issue.
This is just a placeholder that this issue exists.

When using NVIM 0.2.2-1 this didn't happen.
A unconfigured tmux, ie. tmux with default settings, but still NVIM 0.2.2-2, produces the same result.

Further details on the tmux Github page.
This task depends upon

Comment by Thomas Preissler (tomtom) - Wednesday, 21 February 2018, 15:08 GMT
Temporarily solution:

<Deleted>, downgraded won't work as neovim 0.2.2-2 is linked against later libraries.
Comment by Thomas Preissler (tomtom) - Wednesday, 21 February 2018, 17:58 GMT
Workaround:

set -as terminal-overrides ',st*:Ss@'

in your tmux.conf


I am raising this issue with ncurses-dev, but also "st", the terminal, to get terminfo entries fixed.
Comment by Christian Hesse (eworm) - Wednesday, 21 February 2018, 19:13 GMT Comment by dx (dx) - Thursday, 08 March 2018, 23:23 GMT
From what I wrote in  FS#57759 :

This issue would be fixed by upgrading the ncurses package to patch 20180224

The changelog for that patch mentions:

- correct Ss/Ms interchange in st-0.7 entry (tmux #1264) -TD
Comment by Sebastian J. Bronner (waschtl) - Wednesday, 06 November 2019, 22:13 GMT
ncurses regularly releases updates to its terminfo database. They are labeled as "Development terminfo source" at

https://invisible-island.net/ncurses/ncurses.html#download_database

but I get the impression that they are intended as release updates to the most recent ncurses release. This impression stems from a couple comments Thomas Dickey (terminfo maintainer) made:

https://github.com/tmux/tmux/issues/1593#issuecomment-460063051
https://lists.gnu.org/archive/html/bug-ncurses/2019-10/msg00071.html

According to @dx, this issue was fixed in the terminfo database from 2018-02-24. The currently available database at the above URL is from 2019-06-09 (which is the most recent version that runs with the released version of ncurses-6.1).

Therefore, it is my opinion that this bug can be solved in one of two ways:

* Split the ncurses package into two: ncurses-terminfo containing /usr/share/terminfo and ncurses containing everything else. ncurses-terminfo can then be kept up to date with the new terminfo database from the URL above.

* Update the terminfo database and release a new version of this package.
Comment by Sebastian J. Bronner (waschtl) - Thursday, 07 November 2019, 16:58 GMT
The Makefile includes support for this:

make install.libs install.progs
make install.data

instead of "make install"

See https://invisible-island.net/ncurses/ncurses.faq.html#config_small

Loading...