Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57594 - [lua51-mpack] should depend on libmpack

Attached to Project: Community Packages
Opened by Chih-Hsuan Yen (yan12125) - Wednesday, 21 February 2018, 11:13 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Thursday, 22 February 2018, 18:21 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

$ lua5.1 -e 'require("mpack")'
lua5.1: error loading module 'mpack' from file '/usr/lib/lua/5.1/mpack.so':
libmpack.so.0: cannot open shared object file: No such file or directory
stack traceback:
[C]: ?
[C]: in function 'require'
(command line):1: in main chunk
[C]: ?

Additional info:
lua51-mpack 1.0.7-1

Steps to reproduce:
See above

This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Thursday, 22 February 2018, 18:21 GMT
Reason for closing:  Fixed
Comment by Doug Newgard (Scimmia) - Wednesday, 21 February 2018, 14:10 GMT
Looks like it was built in a dirty chroot, so it was missed.
Comment by Eli Schwartz (eschwartz) - Wednesday, 21 February 2018, 15:35 GMT
#archlinux:

10:33 AM <blueyed> svenstaro: the depends for lua51-mpack seem to be broken: it should include libmpack, but that gets overridden in package_lua51-mpack. Ref: https://git.archlinux.org/svntogit/community.git/commit/trunk?h=packages/lua-mpack&id=6f4c9b7a952b781ee1e6a29a2469db359ae7be2f


sven, you can use depends+=() in the split package function for things like this. :)
Comment by Doug Newgard (Scimmia) - Wednesday, 21 February 2018, 15:47 GMT
Oh, my bad, not a dirty chroot then. I missed it.
Comment by Sven-Hendrik Haase (Svenstaro) - Thursday, 22 February 2018, 18:09 GMT
My bad, didn't notice it was being overwritten.

Loading...