Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57578 - [linux] Kernel 4.15.3-2 hangs on boot if I do not blacklist nvidiafb

Attached to Project: Arch Linux
Opened by Andreas (AndreasGB) - Tuesday, 20 February 2018, 09:22 GMT
Last edited by Eli Schwartz (eschwartz) - Monday, 26 February 2018, 16:21 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
Upgrading to the newest kernel caused my laptop to hang on boot, when booting with loglevel=7 the last thing it displayed was something like this (typed it from screen):

[11.268367] i915 0000:00:02.0: enabling device (0006 -> 0007)
[11.273748] [drm] Memory usable by graphics device = 2048M
Starting Update UTMP about System Boot/Shutdown....
[11.275607] fb: switching to inteldrmfb from EFI VGA

Blacklisting nvidiafb fixed the problem.

Forum thread where I asked for help and another user has the same issue: https://bbs.archlinux.org/viewtopic.php?pid=1769154


Additional info:
* Broken package: linux 4.15.3-2, working package: linux-4.14.15-1

* I also found a crash in my system logs, but I do not know anymore which boot parameters were used,
could also have been something like nomodeset causing it.

Feb 19 20:34:00 Katana kernel: ---[ end trace 3e3383d92b762bea ]---
Feb 19 20:34:00 Katana kernel: RIP: nvGetClocks+0x74/0x260 [nvidiafb] RSP: ffff9fdf41ffb798
Feb 19 20:34:00 Katana kernel: Code: 00 41 81 e2 f0 fe 00 00 41 81 fa 90 02 00 00 74 11 41 89 db c1 eb 10 0f b6 db 41 c1 eb 18 44 0f af cb 0f af c2 31 d2 41 0f af c3 <41> f7 f1 d3 e8 89 06 48 8b 87 40 11 00 00 8b 88 00 40 00 00 8b
Feb 19 20:34:00 Katana kernel: R13: 000055f34ec99920 R14: 0000000000020000 R15: 00007ffdd14a8de0
Feb 19 20:34:00 Katana kernel: R10: 0000000000000005 R11: 0000000000000246 R12: 000055f34f4e1000
Feb 19 20:34:00 Katana kernel: RBP: 00007f5a4cc28cb5 R08: 0000000000000006 R09: 00007ffdd14a73d0
Feb 19 20:34:00 Katana kernel: RDX: 00007f5a4cc28cb5 RSI: 0000000000015250 RDI: 000055f34f4e1000
Feb 19 20:34:00 Katana kernel: RAX: ffffffffffffffda RBX: 000055f34ecadac0 RCX: 00007f5a4d3706ca
Feb 19 20:34:00 Katana kernel: RSP: 002b:00007ffdd14a82e8 EFLAGS: 00000246 ORIG_RAX: 00000000000000af
Feb 19 20:34:00 Katana kernel: RIP: 0033:0x7f5a4d3706ca
Feb 19 20:34:00 Katana kernel: entry_SYSCALL_64_after_hwframe+0x21/0x86
Feb 19 20:34:00 Katana kernel: do_syscall_64+0x75/0x190
Feb 19 20:34:00 Katana kernel: SyS_init_module+0x163/0x1a0
Feb 19 20:34:00 Katana kernel: ? SyS_init_module+0x163/0x1a0
Feb 19 20:34:00 Katana kernel: ? vmap_page_range_noflush+0x27b/0x380
Feb 19 20:34:00 Katana kernel: ? kmem_cache_alloc_node_trace+0xe5/0x1d0
Feb 19 20:34:00 Katana kernel: load_module+0x26ad/0x2b30
Feb 19 20:34:00 Katana kernel: do_init_module+0x5b/0x205
Feb 19 20:34:00 Katana kernel: ? kmem_cache_alloc_trace+0xa1/0x1c0
Feb 19 20:34:00 Katana kernel: ? free_unref_page_commit+0x66/0xf0
Feb 19 20:34:00 Katana kernel: do_one_initcall+0x4e/0x190
Feb 19 20:34:00 Katana kernel: ? nvidiafb_resume+0x90/0x90 [nvidiafb]
Feb 19 20:34:00 Katana kernel: driver_register+0x57/0xc0
Feb 19 20:34:00 Katana kernel: ? nvidiafb_resume+0x90/0x90 [nvidiafb]
Feb 19 20:34:00 Katana kernel: bus_add_driver+0x1c2/0x260
Feb 19 20:34:00 Katana kernel: bus_for_each_dev+0x6b/0xb0
Feb 19 20:34:00 Katana kernel: ? driver_probe_device+0x480/0x480
Feb 19 20:34:00 Katana kernel: __driver_attach+0xa0/0xe0
Feb 19 20:34:00 Katana kernel: driver_probe_device+0x315/0x480
Feb 19 20:34:00 Katana kernel: pci_device_probe+0x146/0x1b0
Feb 19 20:34:00 Katana kernel: ? pci_match_device+0xd9/0x100
Feb 19 20:34:00 Katana kernel: local_pci_probe+0x42/0xa0
Feb 19 20:34:00 Katana kernel: nvidiafb_probe+0x612/0x9e0 [nvidiafb]
Feb 19 20:34:00 Katana kernel: register_framebuffer+0x248/0x350
Feb 19 20:34:00 Katana kernel: ? down+0x12/0x50
Feb 19 20:34:00 Katana kernel: blocking_notifier_call_chain+0x3e/0x60
Feb 19 20:34:00 Katana kernel: notifier_call_chain+0x47/0x70
Feb 19 20:34:00 Katana kernel: do_fbcon_takeover+0x58/0xb0
Feb 19 20:34:00 Katana kernel: do_take_over_console+0x7b/0x190
Feb 19 20:34:00 Katana kernel: do_bind_con_driver+0x1f4/0x400
Feb 19 20:34:00 Katana kernel: visual_init+0xd5/0x130
Feb 19 20:34:00 Katana kernel: fbcon_init+0x482/0x660
Feb 19 20:34:00 Katana kernel: nvidiafb_set_par+0x471/0xa00 [nvidiafb]
Feb 19 20:34:00 Katana kernel: ? kmem_cache_alloc_trace+0xa1/0x1c0
Feb 19 20:34:00 Katana kernel: ? kmem_cache_alloc_trace+0x183/0x1c0
Feb 19 20:34:00 Katana kernel: NVCalcStateExt+0x636/0x8d0 [nvidiafb]
Feb 19 20:34:00 Katana kernel: Call Trace:
Feb 19 20:34:00 Katana kernel: CR2: 000055f34eca84a8 CR3: 000000042833a001 CR4: 00000000001606e0
Feb 19 20:34:00 Katana kernel: CS: 0010 DS: 0000 ES: 0000 CR0: 0000000080050033
Feb 19 20:34:00 Katana kernel: FS: 00007f5a4da418c0(0000) GS:ffff8a0cfe240000(0000) knlGS:0000000000000000
Feb 19 20:34:00 Katana kernel: R13: 0000000000000010 R14: 0000000000050000 R15: 0000000000000008
Feb 19 20:34:00 Katana kernel: R10: 0000000000001290 R11: 00000000000000ba R12: 0000000000006247
Feb 19 20:34:00 Katana kernel: RBP: ffff8a0ce7694510 R08: ffff9fdf41ffb7ec R09: 0000000000000000
Feb 19 20:34:00 Katana kernel: RDX: 0000000000000000 RSI: ffff9fdf41ffb7d8 RDI: ffff8a0ce7694418
Feb 19 20:34:00 Katana kernel: RAX: 000000000516b430 RBX: 00000000000000df RCX: 0000000000000007
Feb 19 20:34:00 Katana kernel: RSP: 0018:ffff9fdf41ffb798 EFLAGS: 00010206
Feb 19 20:34:00 Katana kernel: RIP: 0010:nvGetClocks+0x74/0x260 [nvidiafb]

You can find the logs of two boots with this error I obtained via journalctl -r -n 10000 > journal.txt, they are untouched I just removed the wifi profile names and other boots.

System I use:
Lenovo T440p
i5-4300M
Intel HD 4600 + Nvidia GeForce 730M
   journal.txt (288.4 KiB)
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Monday, 26 February 2018, 16:21 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.15.5-1
Comment by Nicola (drakkan) - Wednesday, 21 February 2018, 22:27 GMT
same problem on T540p, blacklisting nvidiafb allows the system to boot,

for me 4.15.3-1 works without the need to blacklist nvidiafb, the problem happen only with 4.15.3-2 on my system
Comment by Philip Müller (philm) - Thursday, 22 February 2018, 06:40 GMT Comment by loqs (loqs) - Friday, 23 February 2018, 21:16 GMT
Can you test if the issue is resolved with linux 4.15.5-1?
Comment by Andreas (AndreasGB) - Saturday, 24 February 2018, 09:29 GMT
It works for me, but I am unsure whether this is because of me having forgotten to remove some way of blacklisting nvidiafb since it does not show up in lsmod or if it is generally being excluded and this is the reason it works.
Comment by DrTea (DrTea) - Monday, 26 February 2018, 08:48 GMT
I had the same boot-issue but did not blacklist nvidiafb (because I have another kernel installed anyways). I can confirm: The 4.15.5-1 upgrade resolved the issue.

Loading...