Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57567 - [python-xapian] package fails to build

Attached to Project: Community Packages
Opened by Erich Eckner (deepthought) - Monday, 19 February 2018, 08:09 GMT
Last edited by David Runge (dvzrv) - Tuesday, 20 February 2018, 16:24 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To David Runge (dvzrv)
Evgeniy Alexeev (arcan1s)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:

Running extra-x86_64-build fails. There seems to be some syntax error in the build commands:

/bin/sh ../libtool --config > libtoolconfig.tmp
. ./libtoolconfig.tmp; cp $objdir/_xapian.cpython-36m-x86_64-linux-gnu.so xapian
rm -f libtoolconfig.tmp
/usr/bin/python3 -c 'import os;os.chdir("xapian");import _xapian'
/usr/bin/python3 -c 'import xapian'
/usr/bin/python3 -O -c 'import os;os.chdir("xapian");import _xapian'
/usr/bin/python3 -O -c 'import xapian'
PYTHONPATH=..:$PYTHONPATH /usr/bin/python3 \
-c 'import sphinx,sys;sys.exit(sphinx.main(sys.argv))' \
-b html -d doctrees -c docs ./docs docs/html
usage: usage: -c [OPTIONS] SOURCEDIR OUTPUTDIR [FILENAMES...]
-c: error: argument -c: expected one argument
make[3]: *** [Makefile:1338: docs/html/index.html] Error 2


Additional info:
* package version(s)
python-xapian 1:1.4.5-2 (git revision 584e8bcea716c8f4eadd79d53e4a6eacc29b624d)

* config and/or log files etc.
full log is attached

Steps to reproduce:
> git checkout 584e8bcea716c8f4eadd79d53e4a6eacc29b624d
> cd python-xapian/repos/community-x86_64
> extra-x86_64-build
This task depends upon

Closed by  David Runge (dvzrv)
Tuesday, 20 February 2018, 16:24 GMT
Reason for closing:  Fixed
Additional comments about closing:  Fixed in 1:1.4.5-3
Comment by David Runge (dvzrv) - Tuesday, 20 February 2018, 16:10 GMT
Seems this was caused by python-sphinx>=1.7.0 and was fixed upstream [1].
I'll rebuild with a patch.

[1] https://github.com/xapian/xapian/commit/13e3ccb4e5cdcc27e5395fc1d2d91045099ddcb1

Loading...