Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57544 - [gitlab] gitlab-10.4.3-1 migration fails

Attached to Project: Community Packages
Opened by Xavier RM (Shtong) - Saturday, 17 February 2018, 11:18 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 21 February 2018, 16:25 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
After updating my system with a pacman -Syu, the installed Gitlab package updated. However, after the update completed, I could not run the migration script without errors, as it fails to load the Rugged library. This is the first time I encounter this problem after an update on this server.

Additional info:

Full list of packages that were included in the update :

Packages (122) bash-4.4.018-1 bluez-libs-5.48-2 bzip2-1.0.6-7 ca-certificates-mozilla-3.35-1 certbot-0.21.1-1 coreutils-8.29-1 cryptsetup-2.0.1-1 curl-7.58.0-1 damageproto-1.2.1-3 [removal] dbus-1.12.4-1 dbus-glib-0.110-1 e2fsprogs-1.43.9-1 ffmpeg-1:3.4.2-1 fixesproto-5.0+9+g4292ec1-1 [removal] freetype2-2.9-2 fribidi-1.0.1+8+gdf7252b-1 gawk-4.2.0-3 gcc-7.3.0-1 gcc-libs-7.3.0-1 gdbm-1.14.1-1 geoip-database-20180206-1 git-2.16.1-1 gitlab-10.4.3-1 gitlab-gitaly-0.82.0-1 gitlab-shell-2:6.0.2-2 gitlab-workhorse-3.5.1-1 glib2-2.54.3+2+g94b38beff-1 glibc-2.26-11 gnupg-2.2.4-2 gnutls-3.5.17-1 gzip-1.9-1 harfbuzz-1.7.5-1 htop-2.1.0-1 http-parser-2.8.0-1 iana-etc-20180131-1 imagemagick-7.0.7.22-1 inputproto-2.3.2-1 [removal] iproute2-4.15.0-1 jemalloc-1:5.0.1-4 kbproto-1.0.7-1 [removal] libice-1.0.9-2 libmagick-7.0.7.22-1 libmariadbclient-10.1.31-1 libmm-glib-1.8rc1+6+g0f377f94-1 libmpc-1.1.0-1 libnftnl-1.0.9-1 libnghttp2-1.30.0-1 libnm-1.10.5dev+3+g5159c34ea-1 libnm-glib-1.10.5dev+3+g5159c34ea-1 libraqm-0.4.0-1 libsasl-2.1.26-12 libseccomp-2.3.2-2 libsystemd-237.31-1 libtasn1-4.13-1 libtheora-1.1.1-4 libtirpc-1.0.2-3 libtool-2.4.6+40+g6ca5e224-4 liburcu-0.10.1-1 libuv-1.19.1-1 libva-2.1.0-1 libvpx-1.7.0-1 libxau-1.0.8-3 libxdamage-1.1.4-3 libxfixes-5.0.3-2 linux-4.15.3-2 linux-firmware-20180119.2a713be-1 lldb-5.0.1-2 llvm-libs-5.0.1-2 lttng-ust-2.10.0-11 lz4-1:1.8.1.2-1 man-db-2.8.1-1 man-pages-4.15-1 mariadb-10.1.31-1 mariadb-clients-10.1.31-1 mesa-17.3.3-2 mono-5.4.1.7-2 mpfr-4.0.0-1 nano-2.9.3-1 networkmanager-1.10.5dev+3+g5159c34ea-1 nodejs-9.5.0-2 nspr-4.18-1 nss-3.35-1 ocl-icd-2.2.12-1 pacman-mirrorlist-20180203-1 patch-2.7.6-1 perl-5.26.1-2 python-3.6.4-2 python-acme-0.21.1-1 python-cffi-1.11.4-1 python-josepy-1.0.1-2 python-pytz-2018.3-1 python-setuptools-1:38.5.1-1 python-werkzeug-0.14.1-1 python2-2.7.14-2 python2-acme-0.21.1-1 python2-cffi-1.11.4-1 python2-josepy-1.0.1-2 python2-psutil-5.4.3-1 python2-pytz-2018.3-1 python2-setuptools-1:38.5.1-1 python2-werkzeug-0.14.1-1 re2-20180201-1 recordproto-1.14.2-2 [removal] redis-4.0.8-2 renderproto-0.11.1-3 [removal] rsync-3.1.3-1 ruby-2.5.0-4 ruby2.3-2.3.5-4 sqlite-3.22.0-1 sudo-1.8.22-1 syslinux-6.03-8 systemd-237.31-1 systemd-sysvcompat-237.31-1 tzdata-2018c-1 v4l-utils-1.14.2-1 vim-8.0.1476-1 vim-runtime-8.0.1476-1 wget-1.19.4-1 xextproto-7.3.0-1 [removal] xf86vidmodeproto-2.3.1-3 [removal] xorgproto-2018.2-1 xproto-7.0.31-1 [removal]

The update output did not contain anything unusual. I saved it in case you need it.

Migration output :

root@myserver:[~]: su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; bundle-2.3 exec rake db:migrate RAILS_ENV=production --trace"
rake aborted!
LoadError: libhttp_parser.so.2.7.1: cannot open shared object file: No such file or directory - /usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rugged-0.26.0/lib/rugged/rugged.so
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rugged-0.26.0/lib/rugged.rb:10:in `require'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rugged-0.26.0/lib/rugged.rb:10:in `rescue in <top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rugged-0.26.0/lib/rugged.rb:6:in `<top (required)>'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:81:in `require'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:81:in `block (2 levels) in require'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:76:in `each'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:76:in `block in require'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:65:in `each'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:65:in `require'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler.rb:114:in `require'
/usr/share/webapps/gitlab/config/application.rb:5:in `<top (required)>'
/usr/share/webapps/gitlab/Rakefile:5:in `require'
/usr/share/webapps/gitlab/Rakefile:5:in `<top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/rake_module.rb:29:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/rake_module.rb:29:in `load_rakefile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:703:in `raw_load_rakefile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:104:in `block in load_rakefile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:186:in `standard_exception_handling'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:103:in `load_rakefile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:82:in `block in run'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:186:in `standard_exception_handling'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:80:in `run'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/exe/rake:27:in `<top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/bin/rake:22:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/bin/rake:22:in `<main>'

Caused by:
LoadError: cannot load such file -- rugged/2.3/rugged
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rugged-0.26.0/lib/rugged.rb:8:in `require'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rugged-0.26.0/lib/rugged.rb:8:in `<top (required)>'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:81:in `require'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:81:in `block (2 levels) in require'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:76:in `each'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:76:in `block in require'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:65:in `each'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler/runtime.rb:65:in `require'
/opt/ruby2.3/lib/ruby/gems/2.3.0/gems/bundler-1.16.0/lib/bundler.rb:114:in `require'
/usr/share/webapps/gitlab/config/application.rb:5:in `<top (required)>'
/usr/share/webapps/gitlab/Rakefile:5:in `require'
/usr/share/webapps/gitlab/Rakefile:5:in `<top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/rake_module.rb:29:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/rake_module.rb:29:in `load_rakefile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:703:in `raw_load_rakefile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:104:in `block in load_rakefile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:186:in `standard_exception_handling'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:103:in `load_rakefile'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:82:in `block in run'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:186:in `standard_exception_handling'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/lib/rake/application.rb:80:in `run'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/gems/rake-12.3.0/exe/rake:27:in `<top (required)>'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/bin/rake:22:in `load'
/usr/share/webapps/gitlab/vendor/bundle/ruby/2.3.0/bin/rake:22:in `<main>'

This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 21 February 2018, 16:25 GMT
Reason for closing:  Not a bug
Comment by Please Delete (balticer) - Saturday, 17 February 2018, 12:11 GMT
Upgraded http-parser-2.8.0-1 is the problem. Workaround is to force a downgrade to previous version.

regards
Kai
Comment by Xavier RM (Shtong) - Saturday, 17 February 2018, 13:12 GMT
Yup, that did the trick. Thanks !
Comment by Please Delete (balticer) - Saturday, 17 February 2018, 13:17 GMT
Anyway, it should be fixed in the gitlab package anyhow. So i think this bug should not be closed, until is fixed.

regards
Kai
Comment by Sven-Hendrik Haase (Svenstaro) - Sunday, 18 February 2018, 01:42 GMT
Can you try the new 10.4.4?
Comment by Please Delete (balticer) - Monday, 19 February 2018, 18:26 GMT
Made
pacman -Suy
then
su - gitlab -s /bin/sh -c "cd '/usr/share/webapps/gitlab'; bundle-2.3 exec rake gitlab:assets:clean gitlab:assets:compile cache:clear RAILS_ENV=production"
got
-> see attached file.

regards
Kai
Comment by Please Delete (balticer) - Monday, 19 February 2018, 18:37 GMT
But it seems to working anyway, hnmm...

regards
Kai
Comment by Xavier RM (Shtong) - Monday, 19 February 2018, 20:25 GMT
Just tried the update, and it all went well (with http-parser-2.8.0-1 installed). I haven't seen any of the errors balticer reported.

Loading...