Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57495 - [xorgproto] Could not satisfy dependencies because of libxfont

Attached to Project: Arch Linux
Opened by Baptiste (zorun) - Tuesday, 13 February 2018, 20:23 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 13 February 2018, 20:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 2
Private No

Details

I cannot upgrade to xorgproto 2018.1-1 because of a dependency issue with libxfont:

:: Starting full system upgrade...
:: Replace compositeproto with extra/xorgproto? [Y/n]
:: Replace damageproto with extra/xorgproto? [Y/n]
:: Replace dmxproto with extra/xorgproto? [Y/n]
:: Replace dri2proto with extra/xorgproto? [Y/n]
:: Replace fixesproto with extra/xorgproto? [Y/n]
:: Replace fontsproto with extra/xorgproto? [Y/n]
:: Replace glproto with extra/xorgproto? [Y/n]
:: Replace inputproto with extra/xorgproto? [Y/n]
:: Replace kbproto with extra/xorgproto? [Y/n]
:: Replace printproto with extra/xorgproto? [Y/n]
:: Replace randrproto with extra/xorgproto? [Y/n]
:: Replace recordproto with extra/xorgproto? [Y/n]
:: Replace renderproto with extra/xorgproto? [Y/n]
:: Replace scrnsaverproto with extra/xorgproto? [Y/n]
:: Replace videoproto with extra/xorgproto? [Y/n]
:: Replace xextproto with extra/xorgproto? [Y/n]
:: Replace xf86dgaproto with extra/xorgproto? [Y/n]
:: Replace xf86vidmodeproto with extra/xorgproto? [Y/n]
:: Replace xineramaproto with extra/xorgproto? [Y/n]
:: Replace xproto with extra/xorgproto? [Y/n]
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: libxfont: removing fontsproto breaks dependency 'fontsproto>=2.1.3'


The issue is that libxfont has a versioned dependency on fontsproto, which xorgproto does not satisfy despite the fact that it provides fontsproto (because of the version number mismatch).

One solution could be to make xorgproto replace libxfont, or simply require people to remove libxfont before upgrading.

I see that libxfont has been dropped from the repositories, so here is what my system knows about it:

Name : libxfont
Version : 1.5.3-1
Description : X11 font rasterisation library
Architecture : x86_64
URL : https://xorg.freedesktop.org/
Licenses : custom
Groups : None
Provides : None
Depends On : freetype2 libfontenc xproto fontsproto>=2.1.3
Optional Deps : None
Required By : None
Optional For : None
Conflicts With : None
Replaces : None
Installed Size : 300.00 KiB
Packager : Laurent Carlier <lordheavym@gmail.com>
Build Date : Fri Oct 20 05:56:59 2017
Install Date : Sun Oct 22 14:23:54 2017
Install Reason : Explicitly installed
Install Script : No
Validated By : Signature
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 13 February 2018, 20:38 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#57393 

Loading...