Community Packages

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57488 - [python-aiohttp] Requires python-idna_ssl for python<3.7

Attached to Project: Community Packages
Opened by Frederik “Freso” S. Olesen (Freso) - Tuesday, 13 February 2018, 10:04 GMT
Last edited by Sven-Hendrik Haase (Svenstaro) - Wednesday, 14 February 2018, 14:08 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Levente Polyak (anthraxx)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 4
Private No

Details

Description:
python-aiohttp currently has python-idna_ssl listed as a check-requirement, but python-aiohttp actually requires idna_ssl to run on Python < 3.7, and `python` in [extra] is 3.6.x (ie., less than 3.7).

See https://github.com/aio-libs/aiohttp/blob/master/setup.py#L72-L73

Additional info:
* package version(s):
** python-aiohttp 2.3.10-1


Steps to reproduce:
* Do not have python-idna_ssl installed
* Run a program that `import`s aiohttp
This task depends upon

Closed by  Sven-Hendrik Haase (Svenstaro)
Wednesday, 14 February 2018, 14:08 GMT
Reason for closing:  Fixed
Comment by Steve M (smmalis37) - Wednesday, 14 February 2018, 03:34 GMT
This should probably be very high priority, as it breaks every python program that uses aiohttp if the user is up-to-date.
Comment by desbma (desbma) - Wednesday, 14 February 2018, 12:19 GMT
I can confirm I am affected by this bug too.

The python-idna_ssl package should be added as a run time dependency for python-aiohttp in the 'depends' PKGBUILD array.

Loading...