Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57479 - [linux] cirrus not able to allocate VRAM under KVM

Attached to Project: Arch Linux
Opened by Marcel Menzel (WRMSR) - Monday, 12 February 2018, 09:23 GMT
Last edited by Doug Newgard (Scimmia) - Saturday, 17 February 2018, 16:15 GMT
Task Type Bug Report
Category Packages: Core
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Hi!

Running the latest Linux or Linux-hardened Kernel (4.15.2) freezes the display output on KVM caused by cirrus:

kernel: fb: switching to cirrusdrmfb from simple
kernel: Console: switching to colour dummy device 80x25
kernel: [drm:cirrus_device_init [cirrus]] *ERROR* can't reserve VRAM
kernel: cirrus 0000:00:02.0: Fatal error during GPU init: -6

So there's no way to interact with a tty rendering the console useless. However, SSH still works. Downgrading to linux-lts solved the problem.

Digging into the problem revealed, that this problem is caused by CONFIG_X86_SYSFB=y in linux and linux-hardened.
This helped: https://lists.debian.org/debian-kernel/2016/11/msg00168.html

linux-lts has: # CONFIG_X86_SYSFB is not set, thats why it is working normal. So, it would be good if you could unset that value for linux and linux-hardened, thanks.

The host's QEMU version is: pc-i440fx-2.8, BIOS version: SeaBIOS 1.10.2-1
This task depends upon

Closed by  Doug Newgard (Scimmia)
Saturday, 17 February 2018, 16:15 GMT
Reason for closing:  Fixed
Additional comments about closing:  linux 4.15.3-2
Comment by Marcel Menzel (WRMSR) - Monday, 12 February 2018, 09:29 GMT
Oops, this should be Category Linux, sorry!
Comment by storrgie (storrgie) - Wednesday, 14 February 2018, 20:24 GMT
It may be this is also causing problems on systems with ipmi/idrac out of band management, as well as KVM/QEMU video...

I should repeat, seeing this on bare-metal (not just QEMU) via those out of band management interfaces (ipmi/iDRAC)
Comment by Sean Enck (enckse) - Wednesday, 14 February 2018, 21:25 GMT
Yeah I believe this is also hitting me on some baremetal using idrac to manage the machines
Comment by Sean Enck (enckse) - Wednesday, 14 February 2018, 22:34 GMT
I compiled 4.15.3-1 with CONFIG_X86_SYSFB not set and that has resolved this issue for me on a test system
Comment by Marcel Menzel (WRMSR) - Wednesday, 14 February 2018, 23:26 GMT
Can confirm, compiled without CONFIG_X86_SYSFB set solved it for me under KVM.
Comment by storrgie (storrgie) - Thursday, 15 February 2018, 13:17 GMT
How likely is it that we'd get this item un-set in the next release?

Also, this isn't just linux-hardened, this is with the default kernel.
Comment by loqs (loqs) - Thursday, 15 February 2018, 13:37 GMT Comment by storrgie (storrgie) - Thursday, 15 February 2018, 13:47 GMT
@loqs, thanks for the update.

Loading...