Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/title/Bug_reporting_guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57477 - [libreoffice-fresh] Impossibleto save GPG encrypted files, General Error

Attached to Project: Arch Linux
Opened by Fran├žois Guerraz (kubrick) - Monday, 12 February 2018, 08:01 GMT
Last edited by Andreas Radke (AndyRTR) - Monday, 05 November 2018, 20:38 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To Andreas Radke (AndyRTR)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:


Additional info:
* package version(s)
extra/libreoffice-fresh 6.0.1-1 [installed]

No logs are produced.


Steps to reproduce:

Create a new file, ctrl-s, choose "Encrypt with GPG", select a key, the following error appears:

Error saving the document Untitled 1:
General Error.
General input/output error

Then it's possible to close the app, without any warning that the file was not saved properly, and the file on disk is corrupted, the document is lost.
This task depends upon

Closed by  Andreas Radke (AndyRTR)
Monday, 05 November 2018, 20:38 GMT
Reason for closing:  Fixed
Comment by Andreas Radke (AndyRTR) - Monday, 12 February 2018, 19:30 GMT
If you have some time please try a rebuild without system xmlsec. Maybe our system library breaks it.
Comment by Andreas Radke (AndyRTR) - Tuesday, 13 February 2018, 18:36 GMT
I could confirm that building with internal xmlsec/libxml2/libxslt doesn't fix it.

Please someone confirm if this bug is also present in the upstream binary distribution or if it is caused by some other Arch system library.
Comment by Fran├žois Guerraz (kubrick) - Saturday, 07 April 2018, 17:23 GMT
It seems to be fixed in libreoffice-fresh-6.0.3-1-x86_64.
Comment by Andreas Radke (AndyRTR) - Monday, 05 November 2018, 20:38 GMT
Works also for me signing and encrypting packages with recent LibO-fresh 6.1.2.

Loading...