Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#57474 - [linux] Kernel general protection fault when trying to use CIFS with 4.15.2-2-ARCH

Attached to Project: Arch Linux
Opened by Daniel Kamil Kozar (XAVeRY) - Sunday, 11 February 2018, 22:36 GMT
Last edited by Doug Newgard (Scimmia) - Tuesday, 13 February 2018, 13:43 GMT
Task Type Bug Report
Category Kernel
Status Assigned
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 10
Private No


When copying files into a CIFS-mounted share on a server in my LAN, the process suddenly stops and a "general protection fault" message along with a stack trace can be seen in the kernel messages. The server is a Samba 4.7.4. The machine usually needs a reboot after the message appears.

Please see the attached file for the full contents of the kernel messages.
This task depends upon

Comment by Daniel Kamil Kozar (XAVeRY) - Wednesday, 14 February 2018, 13:37 GMT
I can't reproduce it anymore under 4.15.3-1-ARCH. Tried writing multiple files into the same directory as before, and everything's working fine.
Comment by Ben Alex (benalexau) - Friday, 02 March 2018, 05:45 GMT
I'm seeing the same behaviour but using 4.15.6-1-ARCH (smbclient 4.7.5-1 to a server with Samba 4.7.5-1). dmesg attached.
Comment by Ben Alex (benalexau) - Friday, 02 March 2018, 06:49 GMT
I have been able to reproduce this bug by:

1. Writing an 800 KB PDF to a CIFS mounted location using a new file name. This first write always works.
2. Attempt to write the same 800 KB PDF again, but to a different file name. This will hang and produce a protection fault.
3. Unmount etc will now hang.

I have found a workaround is to add "vers=1.0" to /etc/fstab:

//FS1/data /home/username/data cifs vers=1.0,credentials=/home/username/smbcredentials,uid=1000

With this workaround the above test can be repeated without any failures, hangs or errors in dmesg.

Comment by neves (neves) - Sunday, 11 March 2018, 23:29 GMT
Same bug here with 4.15.8-1-ARCH #1 SMP PREEMPT Sat Mar 10 00:00:33 UTC 2018 x86_64 GNU/Linux and Samba (server) 4.4.16.

smbclient version 4.7.5
mount.cifs version 6.7

mount options in fstab:
Comment by Jonathan Liu (net147) - Thursday, 12 April 2018, 01:54 GMT
I also have the same crash on 4.15.15-1.
Comment by Marty Barlow (martinbarlow) - Tuesday, 26 June 2018, 22:12 GMT
Observed same issue in ubuntu
Comment by webdawg (webdawg) - Wednesday, 05 September 2018, 22:30 GMT
can someone test this w/ vers 2.0 and 2.1

Just wondering why we went back all the way to 1.0 here

I will be doing some tests here soon, and can report.

has this been thrown upstream? i see on the ubuntu tracker that they have an upstream tag, but does that throw anything upstream?
Comment by Marty Barlow (martinbarlow) - Sunday, 09 September 2018, 11:15 GMT
I tried 2.1 in and could not reproduce issue. Only with 3.0
Comment by Marty Barlow (martinbarlow) - Saturday, 15 September 2018, 19:30 GMT
Actually, i hit it with 2.1, then 2.0 sadly. Now back on 1.0 again.
Comment by loqs (loqs) - Saturday, 15 September 2018, 21:01 GMT
If it is still happening with 4.18 that would be three kernel releases that have passed without a fix (4.16,4.17,4.18) it would seem reasonable to conclude upstream (
is not aware of the issue or believes it has already been resolved. I would suggest testing 4.19-rc3 to see if the issue is still present and if so contact upstream.
Comment by Marty Barlow (martinbarlow) - Sunday, 07 October 2018, 19:02 GMT