Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57473 - [open-vm-tools] missing xf86-video-vmware dep?

Attached to Project: Community Packages
Opened by Jason Papakostas (vith) - Sunday, 11 February 2018, 22:01 GMT
Last edited by Doug Newgard (Scimmia) - Wednesday, 14 February 2018, 00:27 GMT
Task Type Bug Report
Category Packages
Status Assigned
Assigned To Christian Hesse (eworm)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 0%
Votes 3
Private No

Details

Description:
Autofit guest screen resolution doesn't work on Wayland without installing xf86-video-vmware

Additional info:
open-vm-tools 6:10.2.0-2
https://github.com/vmware/open-vm-tools/issues/22#issuecomment-362705505

Should it be an optdep at least? Maybe a full dep? I'm not sure which.
This task depends upon

Comment by Doug Newgard (Scimmia) - Tuesday, 13 February 2018, 13:26 GMT
Wait, it needs the XOrg DDX on Wayland? That sounds insane.
Comment by Jason Papakostas (vith) - Tuesday, 13 February 2018, 19:09 GMT
It surprised me too... I went months without autofit working not realizing that was why.

I don't know the technical reason, just that installing xf86-video-vmware does fix it.

Loading...