Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57428 - [ncurses] Can't launch wine programs from terminals that are xterm-256color

Attached to Project: Arch Linux
Opened by Mika Attila (solvedsnake) - Thursday, 08 February 2018, 07:53 GMT
Last edited by Bartłomiej Piotrowski (Barthalion) - Wednesday, 14 February 2018, 06:20 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To Bartłomiej Piotrowski (Barthalion)
Architecture All
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No

Details

Description:
Running programs with wine from xfce4-terminal, wine prints `'xterm-256color': unknown terminal type.`, then exits, refusing to continue.

Reverting to extra/ncurses fixes this problem.

Running wine from xterm, or setting $TERM to xterm also works.

This is just a guess, but could this have to do with the fact that lib32-ncurses is still the old version?

Additional info:
* package version(s): 6.1-3
* config and/or log files etc.


Steps to reproduce:
Run winecfg from xfce4-terminal
This task depends upon

Closed by  Bartłomiej Piotrowski (Barthalion)
Wednesday, 14 February 2018, 06:20 GMT
Reason for closing:  Fixed
Additional comments about closing:  lib32-ncurses 6.1-1
Comment by Chih-Hsuan Yen (yan12125) - Thursday, 08 February 2018, 09:26 GMT
On my machine TERM=xterm winecfg works while TERM=xterm-256color fails. I suspect this is related to the new "wide" terminfo format (01036) in ncurses 6.1.
Comment by Mika Attila (solvedsnake) - Sunday, 11 February 2018, 06:53 GMT
  • Field changed: Percent Complete (100% → 0%)
 FS#57300  was closed, citing `slang 2.3.1a-2`.

The issue still persists even with the cited slang version.

Moreover, slang doesn't seem to be a dependency of wine, so these seem unrelated issues.
Comment by Eli Schwartz (eschwartz) - Sunday, 11 February 2018, 06:56 GMT
Whether the package is lib32-ncurses or slang, the issue is that things need to be updated to support the latest version of ncurses.
Comment by Mika Attila (solvedsnake) - Sunday, 11 February 2018, 07:34 GMT
I'll just add here as a note that rustup (and rustc installed by rustup) stops producing colored output on xterm-256color and ncurses 6.1. Perhaps they need to be updated (rebuilt against latest ncurses?) as well. How would this work for the rustup installed rustc? Would we need to tell upstream to start producing binaries built against ncurses 6.1? Wouldn't this break all systems that are still using ncurses<6.1?
Comment by Bartłomiej Piotrowski (Barthalion) - Tuesday, 13 February 2018, 08:06 GMT
Pushed new lib32-ncurses to multilib-testing that should fix the problem – please confirm so I can finally move everything to stable…

No idea how rustc colors its output. I can look at it in the free time but that's something to report upstream.

Loading...