Arch Linux

Please read this before reporting a bug:

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!

FS#57412 - [linux] [linux-zen] 4.15.x Boot freezes on Dell Precision 7510

Attached to Project: Arch Linux
Opened by Andrea Girotto (andreagi) - Wednesday, 07 February 2018, 11:45 GMT
Last edited by Antonio Rojas (arojas) - Monday, 03 February 2020, 14:20 GMT
Task Type Bug Report
Category Kernel
Status Closed
Assigned To Tobias Powalowski (tpowa)
Jan Alexander Steffens (heftig)
Architecture x86_64
Severity Critical
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 0
Private No


With kernels 4.15.x the boot freezes on a black screen (immediately after selecting the image on the systemd-boot menu).

The command line for a "normal" boot is:

quiet rw

and I got a black screen (not even the systemd release info) after changing the kernel command line to:

rw earlyprintk=efi,keep pcie_aspm=off acpi=off debug sysrq_always_enabled loglevel=7

There are some white bars coming up from the bottom of the screen (see attached photo)

Additional info:
Laptop: Dell Precision 7510

Linux LTS 4.14.17 boots correctly, the previous release (Linux 4.14.15) too.

I have a NVidia card, so just to see what happens, I added on the kernel command line:

radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=0 amdgpu.cik_support=0 ignore_loglevel

but got the same behaviour (black screen with white bar growing from the bottom) as the one describe above

Steps to reproduce:
1. turn on the device
2. from the systemd-boot menu select the Archlinux "linux" (or "linux-zen") kernel
This task depends upon

Closed by  Antonio Rojas (arojas)
Monday, 03 February 2020, 14:20 GMT
Reason for closing:  Fixed
Comment by loqs (loqs) - Wednesday, 07 February 2018, 14:55 GMT
Which driver is used for the nvidia card? Is late or early modesetting used? If you blacklist the nvidia or nouveau module whichever is used and disable modesetting any change?
Comment by Andrea Girotto (andreagi) - Wednesday, 07 February 2018, 17:04 GMT
I got the same problem trying to boot (both linux & linux-zen, and out of desperation I tried also testing/linux-zen 4.15.1-3 with the same outcome) with the kernel's commandline:

rw earlyprintk=efi,keep pcie_aspm=force acpi=off debug ignore_loglevel sysrq_always_enabled radeon.si_support=0 radeon.cik_support=0 amdgpu.si_support=0 amdgpu.cik_support=0 modprobe.blacklist=amdgpu nomodeset i915.modeset=0 nouveau.modeset=0

result: black screen with white rows growing from the bottom of the screen.
(just to be clear: I know that my system is Nvidia-based and using the proprietary driver and I know that most of that options should not apply, but I have two entries on the systemd-boot to check for this problem and keep modify them).

It is an Optimus system (early KMS), using the nvidia proprietary driver, but the module is not loaded (I use the linux-lts to check this) until I launch a program with "primusrun".
For example this is the modules' list before (first command) and after (second command) running "primusrun firefox":

# lsmod | grep -i nvidia
# lsmod | grep -i nvidia
nvidia_modeset 1097728 1
nvidia 14356480 78 nvidia_modeset
ipmi_msghandler 49152 2 nvidia,ipmi_devintf

so the module is not loaded util needed by a primusrun/optirun/optiprime.

Anyway (again: just-in-case) I added intel_agp and i915 on the mkinitcpio MODULES configuration, after the "mkinitcpio -p linux", got the same problem.
Comment by Andrea Girotto (andreagi) - Wednesday, 07 February 2018, 18:45 GMT
I downloaded from the Dell website the update for the BIOS (it was 1.3.12).
Now it is:

Feb 07 19:37:19 thealeph kernel: DMI: Dell Inc. Precision 7510/0692Y5, BIOS 1.15.4 12/08/2017

and this solved the problem.

Now both the kernels testing/linux-zen 4.15.1-3 and linux 4.15.1-2 load correctly (as soon as I select the item from systemd-boot menu, I see the "systemd 237" and the boot process goes correctly).