Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in Unsupported. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57393 - Error update

Attached to Project: Arch Linux
Opened by Denis Klester (dini) - Tuesday, 06 February 2018, 11:54 GMT
Last edited by Eli Schwartz (eschwartz) - Tuesday, 13 February 2018, 06:31 GMT
Task Type Bug Report
Category Packages: Testing
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 18
Private No

Details

$ sudo pacman -Suy
:: Synchronizing package databases...
testing is up to date
core is up to date
extra is up to date
community-testing is up to date
community is up to date
multilib-testing is up to date
multilib is up to date
sublime-text is up to date
archlinuxfr is up to date
:: Starting full system upgrade...
:: Replace compositeproto with testing/xorgproto? [Y/n]
:: Replace damageproto with testing/xorgproto? [Y/n]
:: Replace dmxproto with testing/xorgproto? [Y/n]
:: Replace dri2proto with testing/xorgproto? [Y/n]
:: Replace dri3proto with testing/xorgproto? [Y/n]
:: Replace fixesproto with testing/xorgproto? [Y/n]
:: Replace fontsproto with testing/xorgproto? [Y/n]
:: Replace glproto with testing/xorgproto? [Y/n]
:: Replace inputproto with testing/xorgproto? [Y/n]
:: Replace kbproto with testing/xorgproto? [Y/n]
:: Replace presentproto with testing/xorgproto? [Y/n]
:: Replace randrproto with testing/xorgproto? [Y/n]
:: Replace recordproto with testing/xorgproto? [Y/n]
:: Replace renderproto with testing/xorgproto? [Y/n]
:: Replace resourceproto with testing/xorgproto? [Y/n]
:: Replace scrnsaverproto with testing/xorgproto? [Y/n]
:: Replace videoproto with testing/xorgproto? [Y/n]
:: Replace xextproto with testing/xorgproto? [Y/n]
:: Replace xf86dgaproto with testing/xorgproto? [Y/n]
:: Replace xf86driproto with testing/xorgproto? [Y/n]
:: Replace xf86vidmodeproto with testing/xorgproto? [Y/n]
:: Replace xineramaproto with testing/xorgproto? [Y/n]
:: Replace xproto with testing/xorgproto? [Y/n]
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: libxfont: removing fontsproto breaks dependency 'fontsproto>=2.1.3'
This task depends upon

Closed by  Eli Schwartz (eschwartz)
Tuesday, 13 February 2018, 06:31 GMT
Reason for closing:  Not a bug
Additional comments about closing:  There's no libxfont package anywhere in our repos
Comment by Eli Schwartz (eschwartz) - Tuesday, 13 February 2018, 06:31 GMT
There is no libxfont in the repos.
libxfont2 is by definition not the same package as libxfont, so in case you were wondering whether it is okay to nag us about irrelevant packages... it really isn't.
If this bug was closed, then either it was closed for a reason, or you think you know more than we do, in which case maybe you should show us all how smart you are by creating and operating your own distro rather than using our sucky bug-ridden distro.

We are now at 11 reopen requests and counting. I suggest you all get it through your heads that this is not a bug and we will not reopen the request. (No, not even to allow you to make irrelevant and out of place comments. This bugtracker is not reddit or Facebook, it is meant for tracking the *status* of bugs and collecting *technical knowledge* about their causes and effects and possible solutions.) So don't be a jerk and try anyway as it is profoundly irritating.

If you are still somehow terribly confused as to what is going on, then given that this is *not a bug*, you really need to learn to take *not a bug* questions to the appropriate medium for *not a bug* support requests, namely, the help forums. It is grossly inappropriate to ask support questions in a medium designed to, well, *track* bugs, as it distracts from the given objective of tracking them!

Although I do strongly recommend you do your due diligence and search for existing forum threads with the same problem, rather than getting the moderators angry at you too -- there are several threads already...

Loading...