Arch Linux

Please read this before reporting a bug:
https://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57365 - [yaml-cpp] [gtest] Conflicting files between yaml-cpp and gtest

Attached to Project: Arch Linux
Opened by Daniel Bermond (Bermond) - Sunday, 04 February 2018, 14:56 GMT
Last edited by Antonio Rojas (arojas) - Sunday, 04 February 2018, 15:08 GMT
Task Type Bug Report
Category Packages: Extra
Status Closed
Assigned To No-one
Architecture x86_64
Severity Low
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 1
Private No

Details

Description:
yaml-cpp has conflicting files with gtest. This was raised by the recent yaml-cpp update (from version 0.5.3-3 to 0.6.1-1).

Both of them provide these files:
usr/include/gtest/gtest-death-test.h
usr/include/gtest/gtest-message.h
usr/include/gtest/gtest-param-test.h
usr/include/gtest/gtest-param-test.h.pump
usr/include/gtest/gtest-printers.h
usr/include/gtest/gtest-spi.h
usr/include/gtest/gtest-test-part.h
usr/include/gtest/gtest-typed-test.h
usr/include/gtest/gtest.h
usr/include/gtest/gtest_pred_impl.h
usr/include/gtest/gtest_prod.h
usr/include/gtest/internal/custom/gtest-port.h
usr/include/gtest/internal/custom/gtest-printers.h
usr/include/gtest/internal/custom/gtest.h
usr/include/gtest/internal/gtest-death-test-internal.h
usr/include/gtest/internal/gtest-filepath.h
usr/include/gtest/internal/gtest-internal.h
usr/include/gtest/internal/gtest-linked_ptr.h
usr/include/gtest/internal/gtest-param-util-generated.h
usr/include/gtest/internal/gtest-param-util-generated.h.pump
usr/include/gtest/internal/gtest-param-util.h
usr/include/gtest/internal/gtest-port-arch.h
usr/include/gtest/internal/gtest-port.h
usr/include/gtest/internal/gtest-string.h
usr/include/gtest/internal/gtest-tuple.h
usr/include/gtest/internal/gtest-tuple.h.pump
usr/include/gtest/internal/gtest-type-util.h
usr/include/gtest/internal/gtest-type-util.h.pump
usr/lib/libgtest.so
usr/lib/libgtest_main.so

Additional info:
yaml-cpp 0.6.1-1
gtest 1.8.0-1
It's not possible to upgrade yaml-cpp from version 0.5.3-3 to 0.6.1-1 in a system upgrade when already having gtest installed, as it's also not possible to install both of them at a first time. pacman will give an error saying about conflicting files.

Steps to reproduce:
# pacman -Syyu yaml-cpp gtest
This task depends upon

Closed by  Antonio Rojas (arojas)
Sunday, 04 February 2018, 15:08 GMT
Reason for closing:  Duplicate
Additional comments about closing:   FS#57361 

Loading...