Community Packages

Please read this before reporting a bug:
http://wiki.archlinux.org/index.php/Reporting_Bug_Guidelines

Do NOT report bugs when a package is just outdated, or it is in the AUR. Use the 'flag out of date' link on the package page, or the Mailing List.

REPEAT: Do NOT report bugs for outdated packages!
Tasklist

FS#57361 - [yaml-cpp] Conflicts with gmock and gtest

Attached to Project: Community Packages
Opened by Sergiu Deitsch (sd) - Sunday, 04 February 2018, 09:43 GMT
Last edited by Baptiste (zorun) - Monday, 05 February 2018, 08:22 GMT
Task Type Bug Report
Category Packages
Status Closed
Assigned To Sven-Hendrik Haase (Svenstaro)
Architecture All
Severity High
Priority Normal
Reported Version
Due in Version Undecided
Due Date Undecided
Percent Complete 100%
Votes 9
Private No

Details

Description:

yaml-cpp unnecessarily installs gtest and gmock files which results in conflicts.


Steps to reproduce:

$ pacman -S gtest gmock yaml-cpp
warning: gtest-1.8.0-1 is up to date -- reinstalling
warning: yaml-cpp-0.6.1-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (3) gmock-1.8.0-1 gtest-1.8.0-1 yaml-cpp-0.6.1-1

Total Download Size: 0,18 MiB
Total Installed Size: 6,15 MiB
Net Upgrade Size: 1,14 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
gmock-1.8.0-1-x86_64 182,1 KiB 1301K/s 00:00 [##############################################################################################] 100%
(3/3) checking keys in keyring [##############################################################################################] 100%
(3/3) checking package integrity [##############################################################################################] 100%
(3/3) loading package files [##############################################################################################] 100%
(3/3) checking for file conflicts [##############################################################################################] 100%
error: failed to commit transaction (conflicting files)
/usr/include/gtest/gtest-death-test.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest-message.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest-param-test.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest-param-test.h.pump exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest-printers.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest-spi.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest-test-part.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest-typed-test.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest_pred_impl.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/gtest_prod.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/custom/gtest-port.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/custom/gtest-printers.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/custom/gtest.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-death-test-internal.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-filepath.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-internal.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-linked_ptr.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-param-util-generated.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-param-util-generated.h.pump exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-param-util.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-port-arch.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-port.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-string.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-tuple.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-tuple.h.pump exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-type-util.h exists in both 'gtest' and 'yaml-cpp'
/usr/include/gtest/internal/gtest-type-util.h.pump exists in both 'gtest' and 'yaml-cpp'
/usr/lib/libgtest.so exists in both 'gtest' and 'yaml-cpp'
/usr/lib/libgtest_main.so exists in both 'gtest' and 'yaml-cpp'
/usr/include/gmock/gmock-actions.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-cardinalities.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-generated-actions.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-generated-function-mockers.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-generated-matchers.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-generated-nice-strict.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-matchers.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-more-actions.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-more-matchers.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock-spec-builders.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/gmock.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/internal/custom/gmock-generated-actions.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/internal/custom/gmock-generated-actions.h.pump exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/internal/custom/gmock-matchers.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/internal/custom/gmock-port.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/internal/gmock-generated-internal-utils.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/internal/gmock-internal-utils.h exists in both 'gmock' and 'yaml-cpp'
/usr/include/gmock/internal/gmock-port.h exists in both 'gmock' and 'yaml-cpp'
/usr/lib/libgmock.so exists in both 'gmock' and 'yaml-cpp'
/usr/lib/libgmock_main.so exists in both 'gmock' and 'yaml-cpp'
Errors occurred, no packages were upgraded.
This task depends upon

Closed by  Baptiste (zorun)
Monday, 05 February 2018, 08:22 GMT
Reason for closing:  Fixed
Additional comments about closing:  yaml-cpp 0.6.1-2
Comment by Lennart N. (AnalogWorm) - Sunday, 04 February 2018, 14:28 GMT Comment by Baptiste (zorun) - Sunday, 04 February 2018, 23:10 GMT
Fixed with yaml-cpp 0.6.1-2
Comment by Levente Polyak (anthraxx) - Sunday, 04 February 2018, 23:49 GMT
why exactly are tests deactivated just because headers are distribured that don't belong there?
Tests should be built and executed, just header files removed
Comment by Baptiste (zorun) - Monday, 05 February 2018, 08:22 GMT
Tests weren't used anyway, and this issue was serious enough to prevent sysupgrade, so disabling tests is the easy way out. I'm sure svenstaro will be able to fix tests properly.

Loading...